Skip to content

← Actionable
Low, CVSS 3.8

lxd CA certificate sign check bypass

CVE-2024-6156GHSA-4c49-9fpc-hc3v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/canonical/lxd 0.0.0-20240708073652-5a492a3f0036), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
EPSS
  • CVE-2024-6156: 0.16% estimated exploitation activity in the next 30 days; percentile 5.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary If a server.ca file is present in LXDDIR at LXD start up, LXD is in "PKI mode". In this mode, only TLS clients that have a CA-signed certificate should be able to authenticate with LXD. We have discovered that if a client that sends a non-CA signed certificate during the TLS handshake, that client is able to authenticate with LXD if their certificate is present in the trust store. - The LXD Go client (and by extension lxc) does not send non-CA signed certificates during the handshake. - A manual client (e.g. cURL) might send a non-CA signed certificate during the handshake. Versions affected LXD 4.0 and above. Details When PKI mode was added to LXD it was intended that all client and server certificates must be signed by the certificate authority (see https://github.com/canonical/lxd/pull/2070/commits/84d917bdcca6fe1e3191ce47f1597c7d094e1909). In PKI mode, the TLS listener configuration is altered to add the CA certificate but the ClientAuth field of tls.Config is not…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4c49-9fpc-hc3v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-6156

Advisory: lxd CA certificate sign check bypass
IDs: CVE-2024-6156, GHSA-4c49-9fpc-hc3v
Record: https://patchnext.com/advisories/cve-2024-6156 (revision 1, source checked 26 Oct 2026, 15:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/canonical/lxd 0.0.0-20240708073652-5a492a3f0036. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/canonical/lxd: affected < 0.0.0-20240708073652-5a492a3f0036; fixed in 0.0.0-20240708073652-5a492a3f0036

## Suggested inspection (read-only)
- Go github.com/canonical/lxd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/canonical/lxd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4c49-9fpc-hc3v (GitHub-reviewed advisory GHSA-4c49-9fpc-hc3v lists affected ranges: Go github.com/canonical/lxd >=0 <0.0.0-20240708073652-5a492a3f0036)

Commands are suggestions: review each one before running it.

Loading voting…