Skip to content

← Actionable
Medium, CVSS 6.5amended

Tornado has a CRLF injection in CurlAsyncHTTPClient headers

CVE-2024-58384GHSA-w235-7p84-xx57

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tornado 6.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tornado

    Affected
    <= 6.4.0
    Fixed in
    6.4.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2024-58384: 0.25% estimated exploitation activity in the next 30 days; percentile 16.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Tornado’s curlhttpclient.CurlAsyncHTTPClient class is vulnerable to CRLF (carriage return/line feed) injection in the request headers. Details When an HTTP request is sent using CurlAsyncHTTPClient, Tornado does not reject carriage return (\r) or line feed (\n) characters in the request headers. As a result, if an application includes an attacker-controlled header value in a request sent using CurlAsyncHTTPClient, the attacker can inject arbitrary headers into the request or cause the application to send arbitrary requests to the specified server. This behavior differs from that of the standard AsyncHTTPClient class, which does reject CRLF characters. This issue appears to stem from libcurl's (as well as pycurl's) lack of validation for the HTTPHEADER option. libcurl’s documentation states: The headers included in the linked list must not be CRLF-terminated, because libcurl adds CRLF after each header item itself. Failure to comply with this might result in strange behavior.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w235-7p84-xx57

  2. Revision 1 · created ·

    Published from osv record GHSA-w235-7p84-xx57

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-58384

Advisory: Tornado has a CRLF injection in CurlAsyncHTTPClient headers
IDs: CVE-2024-58384, GHSA-w235-7p84-xx57
Record: https://patchnext.com/advisories/cve-2024-58384 (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tornado 6.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tornado: affected <= 6.4.0; fixed in 6.4.1

## Suggested inspection (read-only)
- `python -m pip show tornado`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tornado.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w235-7p84-xx57 (OSV record GHSA-w235-7p84-xx57 lists affected ranges: PyPI tornado >=0 <6.4.1 (fixed))
- Verified: https://github.com/advisories/GHSA-w235-7p84-xx57 (GitHub-reviewed advisory GHSA-w235-7p84-xx57 lists affected ranges: PyPI tornado >=0 <=6.4.0)

Commands are suggestions: review each one before running it.

Loading voting…