Uncaught Exception processing HTTP Headers in SurrealDB
CVE-2024-58368GHSA-m24x-r6q3-2vp9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (surrealdb 1.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io surrealdb
- Affected
- < 1.1.0
- Fixed in
- 1.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m24x-r6q3-2vp9 lists affected ranges: crates.io surrealdb >=0 <1.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-58368: 0.65% estimated exploitation activity in the next 30 days; percentile 51.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The ID, DB and NS headers accepted by the SurrealDB HTTP REST API would fail to parse when containing some special characters. This would cause a panic which would crash the SurrealDB server, leading to denial of service. This issue only affects the SurrealDB binary; it does not affect the SurrealDB library. Impact An unauthenticated client may issue an HTTP request to the SurrealDB HTTP REST API containing one of the affected headers with values containing special characters in order to crash the SurrealDB server. This does not require the SurrealDB server to be running with any specific capabilities other than exposing the affected interface. Patches - Version 1.1.0 and later are not affected by this issue. Workarounds Concerned users unable to update may want to limit untrusted access to the SurrealDB HTTP REST API unless such access is required by the application. To limit the impact of the denial of service, SurrealDB administrators may also want to ensure that the SurrealDB…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m24x-r6q3-2vp9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-58368 Advisory: Uncaught Exception processing HTTP Headers in SurrealDB IDs: CVE-2024-58368, GHSA-m24x-r6q3-2vp9 Record: https://patchnext.com/advisories/cve-2024-58368 (revision 1, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: surrealdb 1.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io surrealdb: affected < 1.1.0; fixed in 1.1.0 ## Suggested inspection (read-only) - crates.io surrealdb: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on surrealdb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m24x-r6q3-2vp9 (GitHub-reviewed advisory GHSA-m24x-r6q3-2vp9 lists affected ranges: crates.io surrealdb >=0 <1.1.0) Commands are suggestions: review each one before running it.
Loading voting…