Rancher CLI SAML authentication is vulnerable to phishing attacks
CVE-2024-58267GHSA-v3vj-5868-2ch2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/rancher 2.12.2, 2.11.6, 2.10.10, 2.9.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.12.0, < 2.12.2>= 2.11.0, < 2.11.6>= 2.10.0, < 2.10.10>= 2.9.0, < 2.9.12
- Fixed in
- 2.11.6, 2.9.12, 2.12.2, 2.10.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v3vj-5868-2ch2 lists affected ranges: Go github.com/rancher/rancher >=2.12.0 =2.11.0 =2.10.0 =2.9.0 <2.9.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2024-58267: 0.24% estimated exploitation activity in the next 30 days; percentile 15.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability has been identified within Rancher Manager whereby the SAML authentication from the Rancher CLI tool is vulnerable to phishing attacks. The custom authentication protocol for SAML-based providers can be abused to steal Rancher’s authentication tokens. Rancher Manager deployments without SAML authentication enabled are not affected by this vulnerability. An attacker can generate a phishing SAML login URL which contains a publicKey and requestId controlled by the attacker. The attacker can then give the link to another user (eg: admin) and if the victim goes to the link unsuspectingly, they might not notice the bad parameters in the URL. The user will be prompted to login and might believe that its session has ended so they need to re-login. By clicking on the link, they will be logged in and an encrypted token will be created with the attacker's public key. The attacker can then decrypt the victim’s Rancher token, enabling the attack Please consult the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v3vj-5868-2ch2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-58267 Advisory: Rancher CLI SAML authentication is vulnerable to phishing attacks IDs: CVE-2024-58267, GHSA-v3vj-5868-2ch2 Record: https://patchnext.com/advisories/cve-2024-58267 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/rancher 2.12.2, 2.11.6, 2.10.10, 2.9.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rancher/rancher: affected >= 2.12.0, < 2.12.2; >= 2.11.0, < 2.11.6; >= 2.10.0, < 2.10.10; >= 2.9.0, < 2.9.12; fixed in 2.11.6, 2.9.12, 2.12.2, 2.10.10 ## Suggested inspection (read-only) - Go github.com/rancher/rancher: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rancher/rancher. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v3vj-5868-2ch2 (GitHub-reviewed advisory GHSA-v3vj-5868-2ch2 lists affected ranges: Go github.com/rancher/rancher >=2.12.0 =2.11.0 =2.10.0 =2.9.0 <2.9.12) Commands are suggestions: review each one before running it.
Loading voting…