Rancher update on users can deny the service to the admin
CVE-2024-58260GHSA-q82v-h4rq-5c86
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/rancher 2.12.2, 2.11.6, 2.10.10, 2.9.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.12.0, < 2.12.2>= 2.11.0, < 2.11.6>= 2.10.0, < 2.10.10>= 2.9.0, < 2.9.12
- Fixed in
- 2.11.6, 2.9.12, 2.12.2, 2.10.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q82v-h4rq-5c86 lists affected ranges: Go github.com/rancher/rancher >=2.12.0 =2.11.0 =2.10.0 =2.9.0 <2.9.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:H
- EPSS
- CVE-2024-58260: 0.46% estimated exploitation activity in the next 30 days; percentile 39.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability has been identified within Rancher Manager where a missing server-side validation on the .username field in Rancher can allow users with update permissions on other User resources to cause denial of access for targeted accounts. Specifically: - Username takeover: A user with permission to update another user’s resource can set its .username to "admin", preventing both the legitimate admin and the affected user from logging in, as Rancher enforces uniqueness at login time. - Account lockout: A user with update permissions on the admin account can change the admin’s username, effectively blocking administrative access to the Rancher UI. This issue enables a malicious or compromised account with elevated update privileges on User resources to disrupt platform administration and user authentication. Note: The users with these permissions to modify accounts and resources are considered as privileged users. For more information, please consult Rancher Manger’s…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q82v-h4rq-5c86
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-58260 Advisory: Rancher update on users can deny the service to the admin IDs: CVE-2024-58260, GHSA-q82v-h4rq-5c86 Record: https://patchnext.com/advisories/cve-2024-58260 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/rancher 2.12.2, 2.11.6, 2.10.10, 2.9.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rancher/rancher: affected >= 2.12.0, < 2.12.2; >= 2.11.0, < 2.11.6; >= 2.10.0, < 2.10.10; >= 2.9.0, < 2.9.12; fixed in 2.11.6, 2.9.12, 2.12.2, 2.10.10 ## Suggested inspection (read-only) - Go github.com/rancher/rancher: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rancher/rancher. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q82v-h4rq-5c86 (GitHub-reviewed advisory GHSA-q82v-h4rq-5c86 lists affected ranges: Go github.com/rancher/rancher >=2.12.0 =2.11.0 =2.10.0 =2.9.0 <2.9.12) Commands are suggestions: review each one before running it.
Loading voting…