Skip to content

← Actionable
High, CVSS 8.2

Rancher affected by unauthenticated Denial of Service

CVE-2024-58259GHSA-4h45-jpvh-6p5j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/rancher 2.12.1, 2.11.5, 2.10.9, 2.9.11, 0.0.0-20250813072957-aee95d4e2a41), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/rancher/rancher

    Affected
    >= 2.12.0, < 2.12.1>= 2.11.0, < 2.11.5>= 2.10.0, < 2.10.9>= 2.9.0, < 2.9.11< 0.0.0-20250813072957-aee95d4e2a41
    Fixed in
    2.10.9, 2.11.5, 0.0.0-20250813072957-aee95d4e2a41, 2.12.1, 2.9.11

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-4h45-jpvh-6p5j lists affected ranges: Go github.com/rancher/rancher >=2.12.0 =2.11.0 =2.10.0 =2.9.0 =0 <0.0.0-20250813072957-aee95d4e2a41

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
EPSS
  • CVE-2024-58259: 0.52% estimated exploitation activity in the next 30 days; percentile 44.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability has been identified within Rancher Manager in which it did not enforce request body size limits on certain public (unauthenticated) and authenticated API endpoints. This allows a malicious user to exploit this by sending excessively large payloads, which are fully loaded into memory during processing. This could result in: - Denial of Service (DoS): The server process may crash or become unresponsive when memory consumption exceeds available resources. - Unauthenticated and authenticated exploitation: While the issue was initially observed in unauthenticated /v3-public/ endpoints, the absence of request body size limits also affected several authenticated APIs, broadening the potential attack surface. It's worth noting that other areas in Rancher do implement safeguards: requests proxied to Kubernetes APIs are subject to built-in size limits enforced by the Kubernetes API server itself, and Norman-based endpoints parse input with predefined size caps. However,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4h45-jpvh-6p5j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-58259

Advisory: Rancher affected by unauthenticated Denial of Service
IDs: CVE-2024-58259, GHSA-4h45-jpvh-6p5j
Record: https://patchnext.com/advisories/cve-2024-58259 (revision 1, source checked 26 Oct 2026, 15:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/rancher 2.12.1, 2.11.5, 2.10.9, 2.9.11, 0.0.0-20250813072957-aee95d4e2a41. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/rancher/rancher: affected >= 2.12.0, < 2.12.1; >= 2.11.0, < 2.11.5; >= 2.10.0, < 2.10.9; >= 2.9.0, < 2.9.11; < 0.0.0-20250813072957-aee95d4e2a41; fixed in 2.10.9, 2.11.5, 0.0.0-20250813072957-aee95d4e2a41, 2.12.1, 2.9.11

## Suggested inspection (read-only)
- Go github.com/rancher/rancher: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/rancher/rancher.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4h45-jpvh-6p5j (GitHub-reviewed advisory GHSA-4h45-jpvh-6p5j lists affected ranges: Go github.com/rancher/rancher >=2.12.0 =2.11.0 =2.10.0 =2.9.0 =0 <0.0.0-20250813072957-aee95d4e2a41)

Commands are suggestions: review each one before running it.

Loading voting…