Skip to content

← Actionable
Critical, CVSS 9.0Exploited · CISA KEV

yiisoft/yii2 Mishandles the Attaching of Behavior Defined by a __class Array Key

CVE-2024-58136GHSA-ggwg-cmwp-46r5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yiisoft/yii2 2.0.52), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
9.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H/E:H
EPSS
  • CVE-2024-58136: 87.76% estimated exploitation activity in the next 30 days; percentile 99.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Yii 2 before 2.0.52 mishandles the attaching of behavior that is defined by an class array key, a CVE-2024-4990 regression, as exploited in the wild in February through April 2025.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-ggwg-cmwp-46r5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-58136

Advisory: yiisoft/yii2 Mishandles the Attaching of Behavior Defined by a `__class` Array Key
IDs: CVE-2024-58136, GHSA-ggwg-cmwp-46r5
Record: https://patchnext.com/advisories/cve-2024-58136 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: yiisoft/yii2 2.0.52. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist yiisoft/yii2: affected < 2.0.52; fixed in 2.0.52

## Suggested inspection (read-only)
- Packagist yiisoft/yii2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yiisoft/yii2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-ggwg-cmwp-46r5 (GitHub-reviewed advisory GHSA-ggwg-cmwp-46r5 lists affected ranges: Packagist yiisoft/yii2 >=0 <2.0.52)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2024-58136 to the Known Exploited Vulnerabilities catalog on 2025-05-02.)

Commands are suggestions: review each one before running it.

Loading voting…