Skip to content

← Actionable
Low, CVSS 2.6

HashiCorp Vault Incorrectly Validated JSON Web Tokens (JWT) Audience Claims

CVE-2024-5798GHSA-32cj-5wx4-gq8p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/vault 1.17.0, 1.16.3, 1.15.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/hashicorp/vault

    Affected
    >= 1.17.0-rc1, <= 1.17.0-rc1>= 1.16.0-rc1, < 1.16.3>= 0.11.0, < 1.15.9
    Fixed in
    1.17.0, 1.15.9, 1.16.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N
EPSS
  • CVE-2024-5798: 0.34% estimated exploitation activity in the next 30 days; percentile 27.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vault and Vault Enterprise did not properly validate the JSON Web Token (JWT) role-bound audience claim when using the Vault JWT auth method. This may have resulted in Vault validating a JWT the audience and role-bound claims do not match, allowing an invalid login to succeed when it should have been rejected. This vulnerability, CVE-2024-5798, was fixed in Vault and Vault Enterprise 1.17.0, 1.16.3, and 1.15.9

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-32cj-5wx4-gq8p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-5798

Advisory: HashiCorp Vault Incorrectly Validated JSON Web Tokens (JWT) Audience Claims
IDs: CVE-2024-5798, GHSA-32cj-5wx4-gq8p
Record: https://patchnext.com/advisories/cve-2024-5798 (revision 1, source checked 26 Oct 2026, 15:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/vault 1.17.0, 1.16.3, 1.15.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/hashicorp/vault: affected >= 1.17.0-rc1, <= 1.17.0-rc1; >= 1.16.0-rc1, < 1.16.3; >= 0.11.0, < 1.15.9; fixed in 1.17.0, 1.15.9, 1.16.3

## Suggested inspection (read-only)
- Go github.com/hashicorp/vault: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/hashicorp/vault.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-32cj-5wx4-gq8p (GitHub-reviewed advisory GHSA-32cj-5wx4-gq8p lists affected ranges: Go github.com/hashicorp/vault >=1.17.0-rc1 =1.16.0-rc1 =0.11.0 <1.15.9)

Commands are suggestions: review each one before running it.

Loading voting…