eazy-logger prototype pollution
CVE-2024-57075GHSA-r7jx-5m6m-cpg9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (eazy-logger 4.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm eazy-logger
- Affected
- <= 4.0.1
- Fixed in
- 4.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r7jx-5m6m-cpg9 lists affected ranges: npm eazy-logger >=0 <4.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r7jx-5m6m-cpg9 lists affected ranges: npm eazy-logger >=0 <=4.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-57075: 0.57% estimated exploitation activity in the next 30 days; percentile 47.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A prototype pollution in the lib.Logger function of eazy-logger v4.0.1 allows attackers to cause a Denial of Service (DoS) via supplying a crafted payload. An attacker can supply a payload with Object.prototype setter to introduce or modify properties within the global prototype chain, causing denial of service (DoS) a the minimum consequence. Moreover, the consequences of this vulnerability can escalate to other injection-based attacks, depending on how the library integrates within the application. For instance, if the polluted property propagates to sensitive Node.js APIs (e.g., childprocess.exec, eval), it could enable an attacker to execute arbitrary commands within the application's context. Proof of Concept
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r7jx-5m6m-cpg9
- Revision 1 · created ·
Published from osv record GHSA-r7jx-5m6m-cpg9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-57075 Advisory: eazy-logger prototype pollution IDs: CVE-2024-57075, GHSA-r7jx-5m6m-cpg9 Record: https://patchnext.com/advisories/cve-2024-57075 (revision 2, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: eazy-logger 4.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm eazy-logger: affected <= 4.0.1; fixed in 4.1.0 ## Suggested inspection (read-only) - `npm ls eazy-logger --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on eazy-logger. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r7jx-5m6m-cpg9 (OSV record GHSA-r7jx-5m6m-cpg9 lists affected ranges: npm eazy-logger >=0 <4.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-r7jx-5m6m-cpg9 (GitHub-reviewed advisory GHSA-r7jx-5m6m-cpg9 lists affected ranges: npm eazy-logger >=0 <=4.0.1) Commands are suggestions: review each one before running it.
Loading voting…