Better Auth has an Open Redirect Vulnerability in Verify Email Endpoint
CVE-2024-56734GHSA-8jhw-6pjj-8723
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.1.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm better-auth
- Affected
- < 1.1.6
- Fixed in
- 1.1.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8jhw-6pjj-8723 lists affected ranges: npm better-auth >=0 <1.1.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8jhw-6pjj-8723 lists affected ranges: npm better-auth >=0 <1.1.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2024-56734: 0.39% estimated exploitation activity in the next 30 days; percentile 32.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An open redirect vulnerability has been identified in the verify email endpoint of Better Auth, potentially allowing attackers to redirect users to malicious websites. This issue affects users relying on email verification links generated by the library. Affected Versions - All versions prior to v1.1.6. Impact Attackers could craft malicious email verification links that exploit the redirect functionality to send users to untrusted domains. This can result in: - Phishing attacks – Users may unknowingly enter sensitive information on fake login pages. - Reputation damage – Trust issues for applications using Better Auth. Vulnerability Details The verify email callback endpoint accepts a callbackURL parameter. Unlike other verification methods, email verification only uses JWT to verify and redirect without proper validation of the target domain. The origin checker is bypassed in this scenario because it only checks for POST requests. An attacker can manipulate this parameter…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8jhw-6pjj-8723
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8jhw-6pjj-8723
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-56734 Advisory: Better Auth has an Open Redirect Vulnerability in Verify Email Endpoint IDs: CVE-2024-56734, GHSA-8jhw-6pjj-8723 Record: https://patchnext.com/advisories/cve-2024-56734 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: better-auth 1.1.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm better-auth: affected < 1.1.6; fixed in 1.1.6 ## Suggested inspection (read-only) - `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on better-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8jhw-6pjj-8723 (OSV record GHSA-8jhw-6pjj-8723 lists affected ranges: npm better-auth >=0 <1.1.6 (fixed)) - Verified: https://github.com/advisories/GHSA-8jhw-6pjj-8723 (GitHub-reviewed advisory GHSA-8jhw-6pjj-8723 lists affected ranges: npm better-auth >=0 <1.1.6) Commands are suggestions: review each one before running it.
Loading voting…