Improper Authentication in CraftCMS two factor authentication plugin
CVE-2024-5658GHSA-96qm-hwhp-2rm8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (born05/craft-twofactorauthentication 3.3.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist born05/craft-twofactorauthentication
- Affected
- < 3.3.4
- Fixed in
- 3.3.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-96qm-hwhp-2rm8 lists affected ranges: Packagist born05/craft-twofactorauthentication >=0 <3.3.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2024-5658: 0.59% estimated exploitation activity in the next 30 days; percentile 48.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The CraftCMS plugin Two-Factor Authentication through 3.3.3 allows reuse of TOTP tokens multiple times within the validity period.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-96qm-hwhp-2rm8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-5658 Advisory: Improper Authentication in CraftCMS two factor authentication plugin IDs: CVE-2024-5658, GHSA-96qm-hwhp-2rm8 Record: https://patchnext.com/advisories/cve-2024-5658 (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: born05/craft-twofactorauthentication 3.3.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist born05/craft-twofactorauthentication: affected < 3.3.4; fixed in 3.3.4 ## Suggested inspection (read-only) - Packagist born05/craft-twofactorauthentication: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on born05/craft-twofactorauthentication. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-96qm-hwhp-2rm8 (GitHub-reviewed advisory GHSA-96qm-hwhp-2rm8 lists affected ranges: Packagist born05/craft-twofactorauthentication >=0 <3.3.4) Commands are suggestions: review each one before running it.
Loading voting…