OXID eShop May Display User Information
CVE-2024-56526GHSA-qqcr-9jfc-35c4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (oxid-esales/oxideshop-metapackage-ce 6.5.5; oxid-esales/oxideshop-ce 6.14.4; oxid-esales/smarty-component 1.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist oxid-esales/oxideshop-metapackage-ce
- Affected
- >= 6.0.0, < 6.5.5
- Fixed in
- 6.5.5
Packagist oxid-esales/oxideshop-ce
- Affected
- >= 6.0.0, < 6.14.4
- Fixed in
- 6.14.4
Packagist oxid-esales/smarty-component
- Affected
- < 1.0.1
- Fixed in
- 1.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qqcr-9jfc-35c4 lists affected ranges: Packagist oxid-esales/oxideshop-ce >=6.0.0 =6.0.0 =0 <1.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2024-56526: 0.37% estimated exploitation activity in the next 30 days; percentile 31.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in OXID eShop before 7. CMS pages in combination with Smarty may display user information if a CMS page contains a Smarty syntax error.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qqcr-9jfc-35c4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-56526 Advisory: OXID eShop May Display User Information IDs: CVE-2024-56526, GHSA-qqcr-9jfc-35c4 Record: https://patchnext.com/advisories/cve-2024-56526 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: oxid-esales/oxideshop-metapackage-ce 6.5.5; oxid-esales/oxideshop-ce 6.14.4; oxid-esales/smarty-component 1.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist oxid-esales/oxideshop-metapackage-ce: affected >= 6.0.0, < 6.5.5; fixed in 6.5.5 - Packagist oxid-esales/oxideshop-ce: affected >= 6.0.0, < 6.14.4; fixed in 6.14.4 - Packagist oxid-esales/smarty-component: affected < 1.0.1; fixed in 1.0.1 ## Suggested inspection (read-only) - Packagist oxid-esales/oxideshop-metapackage-ce: check the installed version with your package manager. - Packagist oxid-esales/oxideshop-ce: check the installed version with your package manager. - Packagist oxid-esales/smarty-component: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on oxid-esales/oxideshop-metapackage-ce, oxid-esales/oxideshop-ce, oxid-esales/smarty-component. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qqcr-9jfc-35c4 (GitHub-reviewed advisory GHSA-qqcr-9jfc-35c4 lists affected ranges: Packagist oxid-esales/oxideshop-ce >=6.0.0 =6.0.0 =0 <1.0.1) Commands are suggestions: review each one before running it.
Loading voting…