Skip to content

← Actionable
High, CVSS 8.6amended

changedetection.io Vulnerable to Improper Input Validation Leading to LFR/Path Traversal

CVE-2024-56509GHSA-j5vv-6wjg-cfr8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (changedetection-io 0.48.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2024-56509: 0.71% estimated exploitation activity in the next 30 days; percentile 53.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Improper input validation in the application can allow attackers to perform local file read (LFR) or path traversal attacks. These vulnerabilities occur when user input is used to construct file paths without adequate sanitization or validation. For example, using file:../../../etc/passwd or file: ///etc/passwd can bypass weak validations and allow unauthorized access to sensitive files. Even though this has been addressed in previous patch, it is still insufficient. Details The check in this line of code is insufficient. The attacker can still bypass this by using: -file:../../../../etc/passwd -file: ///etc/passwd (with space before /) PoC - Open up a changedetection.io instance with a webdriver configured. - Create a new watch with file:../../../../etc/passwd. - Check the watch preview. - The contents of /etc/passwd should pop out. Screenshots

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j5vv-6wjg-cfr8

  2. Revision 1 · created ·

    Published from osv record GHSA-j5vv-6wjg-cfr8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-56509

Advisory: changedetection.io Vulnerable to Improper Input Validation Leading to LFR/Path Traversal
IDs: CVE-2024-56509, GHSA-j5vv-6wjg-cfr8
Record: https://patchnext.com/advisories/cve-2024-56509 (revision 2, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: changedetection-io 0.48.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI changedetection-io: affected < 0.48.5; fixed in 0.48.5

## Suggested inspection (read-only)
- `python -m pip show changedetection-io`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on changedetection-io.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j5vv-6wjg-cfr8 (OSV record GHSA-j5vv-6wjg-cfr8 lists affected ranges: PyPI changedetection-io >=0 <0.48.05 (fixed))
- Verified: https://github.com/advisories/GHSA-j5vv-6wjg-cfr8 (GitHub-reviewed advisory GHSA-j5vv-6wjg-cfr8 lists affected ranges: PyPI changedetection-io >=0 <0.48.5)

Commands are suggestions: review each one before running it.

Loading voting…