Skip to content

← Actionable
High, CVSS 8.3

PhpSpreadsheet allows unauthorized Reflected XSS in Currency.php file

CVE-2024-56409GHSA-j2xg-cjcx-4677

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpoffice/phpexcel

    Affected
    <= 1.8.2
    Fixed in
    no fixed version recorded
  • Packagist phpoffice/phpspreadsheet

    Affected
    >= 3.0.0, < 3.7.0<= 1.29.6>= 2.0.0, <= 2.1.5>= 2.2.0, <= 2.3.4
    Fixed in
    2.3.5, 3.7.0, 1.29.7, 2.1.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:H/VA:N/SC:L/SI:H/SA:L · score source
EPSS
  • CVE-2024-56409: 0.34% estimated exploitation activity in the next 30 days; percentile 27.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Unauthorized Reflected XSS in Currency.php file Product: Phpspreadsheet Version: version 3.6.0 CWE-ID: CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') CVSS vector v.3.1: 8.2 (AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:N) CVSS vector v.4.0: 8.3 (AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:H/VA:N/SC:L/SI:H/SA:L) Description: using the /vendor/phpoffice/phpspreadsheet/samples/Wizards/NumberFormat/Currency.php script, an attacker can perform XSS-type attack Impact: executing arbitrary JavaScript code in the browser Vulnerable component: the /vendor/phpoffice/phpspreadsheet/samples/Wizards/NumberFormat/Currency.php file Exploitation conditions: an unauthorized user Mitigation: sanitization of the currency variable Researcher: Aleksey Solovev (Positive Technologies) Research The researcher discovered zero-day vulnerability Unauthorized Reflected Cross-Site Scripting (XSS) (in Currency.php file) in Phpspreadsheet. There is no sanitization in the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j2xg-cjcx-4677

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-56409

Advisory: PhpSpreadsheet allows unauthorized Reflected XSS in Currency.php file
IDs: CVE-2024-56409, GHSA-j2xg-cjcx-4677
Record: https://patchnext.com/advisories/cve-2024-56409 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: phpoffice/phpspreadsheet 3.7.0, 2.3.5, 2.1.6, 1.29.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpoffice/phpexcel: affected <= 1.8.2
- Packagist phpoffice/phpspreadsheet: affected >= 3.0.0, < 3.7.0; <= 1.29.6; >= 2.0.0, <= 2.1.5; >= 2.2.0, <= 2.3.4; fixed in 2.3.5, 3.7.0, 1.29.7, 2.1.6

## Suggested inspection (read-only)
- Packagist phpoffice/phpexcel: check the installed version with your package manager.
- Packagist phpoffice/phpspreadsheet: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpoffice/phpexcel, phpoffice/phpspreadsheet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j2xg-cjcx-4677 (GitHub-reviewed advisory GHSA-j2xg-cjcx-4677 lists affected ranges: Packagist phpoffice/phpspreadsheet >=3.0.0 =0 =2.0.0 =2.2.0 =0 <=1.8.2)

Commands are suggestions: review each one before running it.

Loading voting…