Skip to content

← Actionable
High, CVSS 8.4amended

Apache Airflow vulnerable to Code Injection in the web-server context via LogTemplate table

CVE-2024-56373GHSA-r837-hpv7-pc2f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 2.11.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2024-56373: 1.23% estimated exploitation activity in the next 30 days; percentile 69.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

DAG Author (who already has quite a lot of permissions) could manipulate database of Airflow 2 in the way to execute arbitrary code in the web-server context, which they should normally not be able to do, leading to potentially remote code execution in the context of web-server (server-side) as a result of a user viewing historical task information. The functionality responsible for that (log template history) has been disabled by default in 2.11.1 and users should upgrade to Airflow 3 if they want to continue to use log template history. They can also manually modify historical log file names if they want to see historical logs that were generated before the last log template change.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r837-hpv7-pc2f

  2. Revision 1 · created ·

    Published from osv record GHSA-r837-hpv7-pc2f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-56373

Advisory: Apache Airflow vulnerable to Code Injection in the web-server context via LogTemplate table
IDs: CVE-2024-56373, GHSA-r837-hpv7-pc2f
Record: https://patchnext.com/advisories/cve-2024-56373 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow 2.11.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow: affected < 2.11.1; fixed in 2.11.1

## Suggested inspection (read-only)
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r837-hpv7-pc2f (OSV record GHSA-r837-hpv7-pc2f lists affected ranges: PyPI apache-airflow >=0 <2.11.1 (fixed))
- Verified: https://github.com/advisories/GHSA-r837-hpv7-pc2f (GitHub-reviewed advisory GHSA-r837-hpv7-pc2f lists affected ranges: PyPI apache-airflow >=0 <2.11.1)

Commands are suggestions: review each one before running it.

Loading voting…