lgsl Stored Cross-Site Scripting vulnerability
CVE-2024-56361GHSA-xx95-62h6-h7v3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tltneon/lgsl 7.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist tltneon/lgsl
- Affected
- < 7.0.0
- Fixed in
- 7.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xx95-62h6-h7v3 lists affected ranges: Packagist tltneon/lgsl >=0 <7.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2024-56361: 0.46% estimated exploitation activity in the next 30 days; percentile 40.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A stored cross-site scripting (XSS) vulnerability was identified in lgsl. The issue arises from improper sanitation of user input. Everyone who accesses this page will be affected by this attack. Details The function lgslquery40 in lgslprotocol.php has implemented an HTTP crawler. This function makes a request to the registered game server, and upon crawling the malicious /info endpoint with our payload, will render our javascript on the info page. This information is being displayed via lgsldetails.php Affected Code: PoC 1. Create a game server with type eco and set the target host and port accordingly to your ttack server. I have crafted this json payload that is being parsed according to the schema and being served on /info 2. Serve the following JSON payload at /info on your handler 3. Access the corresponding server info page at /s?=. Upon refreshing & crawling our server, it should execute our javascript.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xx95-62h6-h7v3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-56361 Advisory: lgsl Stored Cross-Site Scripting vulnerability IDs: CVE-2024-56361, GHSA-xx95-62h6-h7v3 Record: https://patchnext.com/advisories/cve-2024-56361 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tltneon/lgsl 7.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist tltneon/lgsl: affected < 7.0.0; fixed in 7.0.0 ## Suggested inspection (read-only) - Packagist tltneon/lgsl: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tltneon/lgsl. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xx95-62h6-h7v3 (GitHub-reviewed advisory GHSA-xx95-62h6-h7v3 lists affected ranges: Packagist tltneon/lgsl >=0 <7.0.0) Commands are suggestions: review each one before running it.
Loading voting…