Skip to content

← Actionable
High, CVSS 7.2

Apache Tomcat Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability

CVE-2024-56337GHSA-27hp-xhwr-wr2m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-embed-core 9.0.98; org.apache.tomcat:tomcat-catalina 11.0.2, 10.1.34; org.apache.tomcat.embed:tomcat-embed-core 11.0.2, 10.1.34, 9.0.98), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-27hp-xhwr-wr2m lists affected ranges: Maven org.apache.tomcat:tomcat-catalina >=11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =11.0.0-M1 =10.1.0-M1 =9.0.0.M1 <9.0.98

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2024-56337: 8.97% estimated exploitation activity in the next 30 days; percentile 95.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.1, from 10.1.0-M1 through 10.1.33, from 9.0.0.M1 through 9.0.97. The mitigation for CVE-2024-50379 was incomplete. Users running Tomcat on a case insensitive file system with the default servlet write enabled (readonly initialisation parameter set to the non-default value of false) may need additional configuration to fully mitigate CVE-2024-50379 depending on which version of Java they are using with Tomcat: - running on Java 8 or Java 11: the system property sun.io.useCanonCaches must be explicitly set to false (it defaults to true) - running on Java 17: the system property sun.io.useCanonCaches, if set, must be set to false (it defaults to false) - running on Java 21 onwards: no further configuration is required (the system property and the problematic cache have been removed) Tomcat 11.0.3, 10.1.35 and 9.0.99 onwards will include checks…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-27hp-xhwr-wr2m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-56337

Advisory: Apache Tomcat Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability
IDs: CVE-2024-56337, GHSA-27hp-xhwr-wr2m
Record: https://patchnext.com/advisories/cve-2024-56337 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-embed-core 9.0.98; org.apache.tomcat:tomcat-catalina 11.0.2, 10.1.34; org.apache.tomcat.embed:tomcat-embed-core 11.0.2, 10.1.34, 9.0.98. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat-embed-core: affected >= 9.0.0.M1, < 9.0.98; fixed in 9.0.98
- Maven org.apache.tomcat:tomcat-catalina: affected >= 11.0.0-M1, < 11.0.2; >= 10.1.0-M1, < 10.1.34; fixed in 10.1.34, 11.0.2
- Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 11.0.0-M1, < 11.0.2; >= 10.1.0-M1, < 10.1.34; >= 9.0.0.M1, < 9.0.98; fixed in 9.0.98, 10.1.34, 11.0.2

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat-embed-core: check the installed version with your package manager.
- Maven org.apache.tomcat:tomcat-catalina: check the installed version with your package manager.
- Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat-embed-core, org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-27hp-xhwr-wr2m (GitHub-reviewed advisory GHSA-27hp-xhwr-wr2m lists affected ranges: Maven org.apache.tomcat:tomcat-catalina >=11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =11.0.0-M1 =10.1.0-M1 =9.0.0.M1 <9.0.98)

Commands are suggestions: review each one before running it.

Loading voting…