Systeminformation has command injection vulnerability in getWindowsIEEE8021x (SSID)
CVE-2024-56334GHSA-cvv5-9h9w-qp2m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (systeminformation 5.23.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 5.23.6
- Fixed in
- 5.23.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cvv5-9h9w-qp2m lists affected ranges: npm systeminformation >=0 <5.23.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cvv5-9h9w-qp2m lists affected ranges: npm systeminformation >=0 <=5.23.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-56334: 0.70% estimated exploitation activity in the next 30 days; percentile 53.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The SSID is not sanitized when before it is passed as a parameter to cmd.exe in the getWindowsIEEE8021x function. This means that malicious content in the SSID can be executed as OS commands. Details I have exploited this vulnerability in a Windows service using version 5.22.11 of the module, to escalate privileges (in an environment where I am authorized to do so). However, as far as I can see from the code, it is still present in master branch at time of writing, on line 403/404 of network.js. The SSID is obtained from netsh wlan show interface ... in getWindowsWirelessIfaceSSID, and then passed to cmd.exe /d /s /c "netsh wlan show profiles ... in getWindowsIEEE8021x, without sanitization. PoC First, the command injection payload should be included in the connected Wi-Fi SSID. For example create hotspot on mobile phone or other laptop, set SSID to payload, connect to it with victim Windows system. Two example SSID's to demonstrate exploitation are below. Demonstration to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cvv5-9h9w-qp2m
- Revision 1 · created ·
Published from osv record GHSA-cvv5-9h9w-qp2m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-56334 Advisory: Systeminformation has command injection vulnerability in getWindowsIEEE8021x (SSID) IDs: CVE-2024-56334, GHSA-cvv5-9h9w-qp2m Record: https://patchnext.com/advisories/cve-2024-56334 (revision 2, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: systeminformation 5.23.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm systeminformation: affected <= 5.23.6; fixed in 5.23.7 ## Suggested inspection (read-only) - `npm ls systeminformation --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on systeminformation. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cvv5-9h9w-qp2m (OSV record GHSA-cvv5-9h9w-qp2m lists affected ranges: npm systeminformation >=0 <5.23.7 (fixed)) - Verified: https://github.com/advisories/GHSA-cvv5-9h9w-qp2m (GitHub-reviewed advisory GHSA-cvv5-9h9w-qp2m lists affected ranges: npm systeminformation >=0 <=5.23.6) Commands are suggestions: review each one before running it.
Loading voting…