Skip to content

← Actionable
Medium, CVSS 5.3amended

Next.js Allows a Denial of Service (DoS) with Server Actions

CVE-2024-56332GHSA-7m27-7ghc-44w9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 15.1.2, 14.2.21, 13.5.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 13.0.0, < 13.5.8>= 14.0.0, < 14.2.21>= 15.0.0, < 15.1.2
    Fixed in
    13.5.8, 14.2.21, 15.1.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2024-56332: 0.80% estimated exploitation activity in the next 30 days; percentile 56.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A Denial of Service (DoS) attack allows attackers to construct requests that leaves requests to Server Actions hanging until the hosting provider cancels the function execution. Note: Next.js server is idle during that time and only keeps the connection open. CPU and memory footprint are low during that time. Deployments without any protection against long running Server Action invocations are especially vulnerable. Hosting providers like Vercel or Netlify set a default maximum duration on function execution to reduce the risk of excessive billing. This is the same issue as if the incoming HTTP request has an invalid Content-Length header or never closes. If the host has no other mitigations to those then this vulnerability is novel. This vulnerability affects only Next.js deployments using Server Actions. Patches This vulnerability was resolved in Next.js 14.2.21, 15.1.2, and 13.5.8. We recommend that users upgrade to a safe version. Workarounds There are no official…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7m27-7ghc-44w9

  2. Revision 1 · created ·

    Published from osv record GHSA-7m27-7ghc-44w9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-56332

Advisory: Next.js Allows a Denial of Service (DoS) with Server Actions
IDs: CVE-2024-56332, GHSA-7m27-7ghc-44w9
Record: https://patchnext.com/advisories/cve-2024-56332 (revision 2, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 15.1.2, 14.2.21, 13.5.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 13.0.0, < 13.5.8; >= 14.0.0, < 14.2.21; >= 15.0.0, < 15.1.2; fixed in 13.5.8, 14.2.21, 15.1.2

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7m27-7ghc-44w9 (OSV record GHSA-7m27-7ghc-44w9 lists affected ranges: npm next >=13.0.0 =14.0.0 =15.0.0 <15.1.2 (fixed))
- Verified: https://github.com/advisories/GHSA-7m27-7ghc-44w9 (GitHub-reviewed advisory GHSA-7m27-7ghc-44w9 lists affected ranges: npm next >=13.0.0 =14.0.0 =15.0.0 <15.1.2)

Commands are suggestions: review each one before running it.

Loading voting…