Skip to content

← Actionable
Medium, CVSS 6.8amended

uptime-kuma vulnerable to Local File Inclusion (LFI) via Improper URL Handling in Real-Browser monitor

CVE-2024-56331GHSA-2qgm-m29m-cj2h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (uptime-kuma 2.0.0-beta.1, 1.23.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm uptime-kuma

    Affected
    >= 1.23.0, < 1.23.16>= 2.0.0-beta.0, <= 2.0.0-beta.0
    Fixed in
    2.0.0-beta.1, 1.23.16

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N
EPSS
  • CVE-2024-56331: 1.85% estimated exploitation activity in the next 30 days; percentile 79.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An Improper URL Handling Vulnerability allows an attacker to access sensitive local files on the server by exploiting the file:/// protocol. This vulnerability is triggered via the "real-browser" request type, which takes a screenshot of the URL provided by the attacker. By supplying local file paths, such as file:///etc/passwd, an attacker can read sensitive data from the server. Details The vulnerability arises because the system does not properly validate or sanitize the user input for the URL field. Specifically: 1. The URL input (<input data-v-5f5c86d7="" id="url" type="url" class="form-control" pattern="https?://.+" required="") allows users to input arbitrary file paths, including those using the file:/// protocol, without server-side validation. 2. The server then uses the user-provided URL to make a request, passing it to a browser instance that performs the "real-browser" request, which takes a screenshot of the content at the given URL. If a local file path is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2qgm-m29m-cj2h

  2. Revision 1 · created ·

    Published from osv record GHSA-2qgm-m29m-cj2h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-56331

Advisory: uptime-kuma vulnerable to Local File Inclusion (LFI) via Improper URL Handling in `Real-Browser` monitor
IDs: CVE-2024-56331, GHSA-2qgm-m29m-cj2h
Record: https://patchnext.com/advisories/cve-2024-56331 (revision 2, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: uptime-kuma 2.0.0-beta.1, 1.23.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm uptime-kuma: affected >= 1.23.0, < 1.23.16; >= 2.0.0-beta.0, <= 2.0.0-beta.0; fixed in 2.0.0-beta.1, 1.23.16

## Suggested inspection (read-only)
- `npm ls uptime-kuma --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on uptime-kuma.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2qgm-m29m-cj2h (OSV record GHSA-2qgm-m29m-cj2h lists affected ranges: npm uptime-kuma >=1.23.0 =2.0.0-beta.0 <2.0.0-beta.1 (fixed))
- Verified: https://github.com/advisories/GHSA-2qgm-m29m-cj2h (GitHub-reviewed advisory GHSA-2qgm-m29m-cj2h lists affected ranges: npm uptime-kuma >=1.23.0 =2.0.0-beta.0 <=2.0.0-beta.0)

Commands are suggestions: review each one before running it.

Loading voting…