Socialstream has a Potential Account Takeover Vulnerability in Social Account Linking Due to Missing User Consent After OAuth Callback
CVE-2024-56329GHSA-3q97-vjpp-c8rp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (joelbutcher/socialstream 6.2.0, 5.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist joelbutcher/socialstream
- Affected
- >= 6.0.0, < 6.2.0< 5.6.0
- Fixed in
- 5.6.0, 6.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3q97-vjpp-c8rp lists affected ranges: Packagist joelbutcher/socialstream >=6.0.0 =0 <5.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2024-56329: 0.58% estimated exploitation activity in the next 30 days; percentile 47.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description When linking a social account to an already authenticated user, the lack of a confirmation step introduces a security risk. This is exacerbated if -stateless() is used in the Socialite configuration, bypassing state verification and making the exploit easier. Developers should ensure that users explicitly confirm account linking and avoid configurations that skip critical security checks. Resolution Socialstream v6.2 introduces a new custom route that requires a user to "Confirm" or "Deny" a request to link a social account.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3q97-vjpp-c8rp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-56329 Advisory: Socialstream has a Potential Account Takeover Vulnerability in Social Account Linking Due to Missing User Consent After OAuth Callback IDs: CVE-2024-56329, GHSA-3q97-vjpp-c8rp Record: https://patchnext.com/advisories/cve-2024-56329 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: joelbutcher/socialstream 6.2.0, 5.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist joelbutcher/socialstream: affected >= 6.0.0, < 6.2.0; < 5.6.0; fixed in 5.6.0, 6.2.0 ## Suggested inspection (read-only) - Packagist joelbutcher/socialstream: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on joelbutcher/socialstream. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3q97-vjpp-c8rp (GitHub-reviewed advisory GHSA-3q97-vjpp-c8rp lists affected ranges: Packagist joelbutcher/socialstream >=6.0.0 =0 <5.6.0) Commands are suggestions: review each one before running it.
Loading voting…