OpenFGA Authorization Bypass
CVE-2024-56323GHSA-32q6-rr98-cjqv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/openfga/openfga 1.8.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.3.8, < 1.8.3
- Fixed in
- 1.8.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-32q6-rr98-cjqv lists affected ranges: Go github.com/openfga/openfga >=1.3.8 <1.8.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2024-56323: 0.44% estimated exploitation activity in the next 30 days; percentile 38.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview OpenFGA v1.3.8 to v1.8.2 (Helm chart openfga-0.1.38 to openfga-0.2.19, docker v1.3.8 to v.1.8.2) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Am I Affected? You are affected by this authorization bypass vulnerability if you are using OpenFGA v1.3.8 to v1.8.2, specifically under the following conditions: 1. Calling Check API or ListObjects with a model that uses conditions, and 2. OpenFGA is configured with caching enabled (OPENFGACHECKQUERYCACHEENABLED), and 3. Check API call or ListObjects API calls contain contextual tuples that include conditions. Fix Upgrade to v1.8.3. This upgrade is backwards compatible.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-32q6-rr98-cjqv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-56323 Advisory: OpenFGA Authorization Bypass IDs: CVE-2024-56323, GHSA-32q6-rr98-cjqv Record: https://patchnext.com/advisories/cve-2024-56323 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/openfga/openfga 1.8.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/openfga/openfga: affected >= 1.3.8, < 1.8.3; fixed in 1.8.3 ## Suggested inspection (read-only) - Go github.com/openfga/openfga: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/openfga/openfga. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-32q6-rr98-cjqv (GitHub-reviewed advisory GHSA-32q6-rr98-cjqv lists affected ranges: Go github.com/openfga/openfga >=1.3.8 <1.8.3) Commands are suggestions: review each one before running it.
Loading voting…