PyMongo Out-of-bounds Read in the bson module
CVE-2024-5629GHSA-m87m-mmvp-v9qm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pymongo 4.6.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pymongo
- Affected
- < 4.6.3
- Fixed in
- 4.6.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m87m-mmvp-v9qm lists affected ranges: PyPI pymongo >=0 <4.6.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m87m-mmvp-v9qm lists affected ranges: PyPI pymongo >=0 <4.6.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:L
- EPSS
- CVE-2024-5629: 0.66% estimated exploitation activity in the next 30 days; percentile 51.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of the package pymongo before 4.6.3 are vulnerable to Out-of-bounds Read in the bson module. Using the crafted payload the attacker could force the parser to deserialize unmanaged memory. The parser tries to interpret bytes next to buffer and throws an exception with string. If the following bytes are not printable UTF-8 the parser throws an exception with a single byte.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-m87m-mmvp-v9qm
- Revision 1 · created ·
Published from osv record GHSA-m87m-mmvp-v9qm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-5629 Advisory: PyMongo Out-of-bounds Read in the bson module IDs: CVE-2024-5629, GHSA-m87m-mmvp-v9qm Record: https://patchnext.com/advisories/cve-2024-5629 (revision 2, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pymongo 4.6.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pymongo: affected < 4.6.3; fixed in 4.6.3 ## Suggested inspection (read-only) - `python -m pip show pymongo`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pymongo. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m87m-mmvp-v9qm (OSV record GHSA-m87m-mmvp-v9qm lists affected ranges: PyPI pymongo >=0 <4.6.3 (fixed)) - Verified: https://github.com/advisories/GHSA-m87m-mmvp-v9qm (GitHub-reviewed advisory GHSA-m87m-mmvp-v9qm lists affected ranges: PyPI pymongo >=0 <4.6.3) Commands are suggestions: review each one before running it.
Loading voting…