path-sanitizer allows bypassing the existing filters to achieve path-traversal vulnerability
CVE-2024-56198GHSA-94p5-r7cc-3rpr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (path-sanitizer 3.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm path-sanitizer
- Affected
- < 3.1.0
- Fixed in
- 3.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-94p5-r7cc-3rpr lists affected ranges: npm path-sanitizer >=0 <3.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-94p5-r7cc-3rpr lists affected ranges: npm path-sanitizer >=0 <3.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-56198: 0.74% estimated exploitation activity in the next 30 days; percentile 54.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary This is a POC for a path-sanitizer npm package. The filters can be bypassed and can result in path traversal. Payload: ..=%5c can be used to bypass this on CLI (along with other candidates). Something similar would likely work on web apps as well. PoC Here's the code to test for the filter bypass: Here is a video POC: (this is a Loom POC, only users with the UUID of the video can see it) https://www.loom.com/share/b766ece5193842848ce7562fcd559256?sid=fd826eb6-0eee-4601-bf0e-9cfee5c56e9d Impact Any CLI tool or library using this package can be/will be vulnerable to Path traversal.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-94p5-r7cc-3rpr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-94p5-r7cc-3rpr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-56198 Advisory: path-sanitizer allows bypassing the existing filters to achieve path-traversal vulnerability IDs: CVE-2024-56198, GHSA-94p5-r7cc-3rpr Record: https://patchnext.com/advisories/cve-2024-56198 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: path-sanitizer 3.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm path-sanitizer: affected < 3.1.0; fixed in 3.1.0 ## Suggested inspection (read-only) - `npm ls path-sanitizer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on path-sanitizer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-94p5-r7cc-3rpr (OSV record GHSA-94p5-r7cc-3rpr lists affected ranges: npm path-sanitizer >=0 <3.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-94p5-r7cc-3rpr (GitHub-reviewed advisory GHSA-94p5-r7cc-3rpr lists affected ranges: npm path-sanitizer >=0 <3.1.0) Commands are suggestions: review each one before running it.
Loading voting…