Skip to content

← Actionable
Critical, CVSS 9.3Exploited · CISA KEV

Craft CMS has potential RCE when PHP register_argc_argv config setting is enabled

CVE-2024-56145GHSA-2p6p-9rc9-62j9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.5.2, 4.13.2, 3.9.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/cms

    Affected
    >= 5.0.0-RC1, < 5.5.2>= 4.0.0-RC1, < 4.13.2>= 3.0.0, < 3.9.14
    Fixed in
    4.13.2, 3.9.14, 5.5.2

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:A · score source
EPSS
  • CVE-2024-56145: 97.48% estimated exploitation activity in the next 30 days; percentile 99.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact You are affected if your php.ini configuration has registerargcargv enabled. Patches Update to 3.9.14, 4.13.2, or 5.5.2. Workarounds If you can't upgrade yet, and registerargcargv is enabled, you can disable it to mitigate the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2p6p-9rc9-62j9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-56145

Advisory: Craft CMS has potential RCE when PHP `register_argc_argv` config setting is enabled
IDs: CVE-2024-56145, GHSA-2p6p-9rc9-62j9
Record: https://patchnext.com/advisories/cve-2024-56145 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.5.2, 4.13.2, 3.9.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/cms: affected >= 5.0.0-RC1, < 5.5.2; >= 4.0.0-RC1, < 4.13.2; >= 3.0.0, < 3.9.14; fixed in 4.13.2, 3.9.14, 5.5.2

## Suggested inspection (read-only)
- Packagist craftcms/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2024-56145 to the Known Exploited Vulnerabilities catalog on 2025-06-02.)
- Verified: https://github.com/advisories/GHSA-2p6p-9rc9-62j9 (GitHub-reviewed advisory GHSA-2p6p-9rc9-62j9 lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 =4.0.0-RC1 =3.0.0 <3.9.14)

Commands are suggestions: review each one before running it.

Loading voting…