LibreNMS Display Name 2 Stored Cross-site Scripting vulnerability
CVE-2024-56144GHSA-2f4w-6mc7-4w78
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 24.12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist librenms/librenms
- Affected
- >= 24.11.10, <= 24.11.10
- Fixed in
- 24.12.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2f4w-6mc7-4w78 lists affected ranges: Packagist librenms/librenms >=24.11.10 <=24.11.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2024-56144: 0.40% estimated exploitation activity in the next 30 days; percentile 33.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
StoredXSS-LibreNMS-Display Name 2 Description: XSS on the parameters (Replace $DEVICEID with your specific $DEVICEID value):/device/$DEVICEID/edit - param: display of Librenms versions 24.11.0 (https://github.com/librenms/librenms) allows remote attackers to inject malicious scripts. When a user views or interacts with the page displaying the data, the malicious script executes immediately, leading to potential unauthorized actions or data exposure. Proof of Concept: 1. Add a new device through the LibreNMS interface. 2. Edit the newly created device by going to the "Device Settings" section. 3. In the "Display Name" field, enter the following payload: "<img src onerror="alert(document.cookie)". 4. Save the changes. 5. The XSS payload is triggered when navigating to the path /device/$DEVICEID/logs and hovering over a type containing a tag (such as Core 1 in the image). Impact: Execution of Malicious Code
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2f4w-6mc7-4w78
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-56144 Advisory: LibreNMS Display Name 2 Stored Cross-site Scripting vulnerability IDs: CVE-2024-56144, GHSA-2f4w-6mc7-4w78 Record: https://patchnext.com/advisories/cve-2024-56144 (revision 1, source checked 26 Oct 2026, 14:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 24.12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist librenms/librenms: affected >= 24.11.10, <= 24.11.10; fixed in 24.12.0 ## Suggested inspection (read-only) - Packagist librenms/librenms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on librenms/librenms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2f4w-6mc7-4w78 (GitHub-reviewed advisory GHSA-2f4w-6mc7-4w78 lists affected ranges: Packagist librenms/librenms >=24.11.10 <=24.11.10) Commands are suggestions: review each one before running it.
Loading voting…