Strapi Allows Unauthorized Access to Private Fields via parms.lookup
CVE-2024-56143GHSA-495j-h493-42q2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strapi/core 5.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @strapi/core
- Affected
- >= 5.0.0, < 5.5.2
- Fixed in
- 5.5.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-495j-h493-42q2 lists affected ranges: npm @strapi/core >=5.0.0 <5.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-495j-h493-42q2 lists affected ranges: npm @strapi/core >=5.0.0 <5.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2024-56143: 0.42% estimated exploitation activity in the next 30 days; percentile 36.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary It's possible to access any private fields by filtering through the lookup parameters Details Using the new lookup operator provided by the document service in Strapi 5, it is not properly sanitizing this query operator for private fields. PoC 1. Create a strapi app. 2. Create a content-type 3. In the content-type you make a new entry 4. Go back to the list view 4. Add &lookup[updatedBy][password][$startsWith]=$2 to the end of your url (All passwords start with $2) see that all entries are still there 6. Add &lookup[updatedBy][password][$startsWith]=$3 see the entry disappear proving that the search above works Impact An attacker can perform filtering attacks on everything related to the object, including admin passwords and reset-tokens. This means that they can gain full access to the strapi instance.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-495j-h493-42q2
- Revision 1 · created ·
Published from osv record GHSA-495j-h493-42q2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-56143 Advisory: Strapi Allows Unauthorized Access to Private Fields via parms.lookup IDs: CVE-2024-56143, GHSA-495j-h493-42q2 Record: https://patchnext.com/advisories/cve-2024-56143 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @strapi/core 5.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @strapi/core: affected >= 5.0.0, < 5.5.2; fixed in 5.5.2 ## Suggested inspection (read-only) - `npm ls @strapi/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @strapi/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-495j-h493-42q2 (OSV record GHSA-495j-h493-42q2 lists affected ranges: npm @strapi/core >=5.0.0 <5.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-495j-h493-42q2 (GitHub-reviewed advisory GHSA-495j-h493-42q2 lists affected ranges: npm @strapi/core >=5.0.0 <5.5.2) Commands are suggestions: review each one before running it.
Loading voting…