Skip to content

← Actionable
Low, CVSS 1.7

Apache Kafka's SCRAM implementation Incorrectly Implements Authentication Algorithm

CVE-2024-56128GHSA-p7c9-8xx8-h74f

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.kafka:kafka_2.10

    Affected
    >= 0.10.2.0, <= 0.10.2.2
    Fixed in
    no fixed version recorded
  • Maven org.apache.kafka:kafka_2.13

    Affected
    >= 0.10.2.0, < 3.7.2>= 3.8.0, <= 3.8.0
    Fixed in
    3.8.1, 3.7.2
  • Maven org.apache.kafka:kafka_2.12

    Affected
    >= 0.10.2.0, < 3.7.2>= 3.8.0, <= 3.8.0
    Fixed in
    3.8.1, 3.7.2
  • Maven org.apache.kafka:kafka_2.11

    Affected
    >= 0.10.2.0, <= 2.4.1
    Fixed in
    no fixed version recorded

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-p7c9-8xx8-h74f lists affected ranges: Maven org.apache.kafka:kafka_2.13 >=0.10.2.0 =3.8.0 =0.10.2.0 =3.8.0 =0.10.2.0 =0.10.2.0 <=0.10.2.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.7 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2024-56128: 0.82% estimated exploitation activity in the next 30 days; percentile 57.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Incorrect Implementation of Authentication Algorithm in Apache Kafka's SCRAM implementation. Issue Summary: Apache Kafka's implementation of the Salted Challenge Response Authentication Mechanism (SCRAM) did not fully adhere to the requirements of RFC 5802 [1]. Specifically, as per RFC 5802, the server must verify that the nonce sent by the client in the second message matches the nonce sent by the server in its first message. However, Kafka's SCRAM implementation did not perform this validation. Impact: This vulnerability is exploitable only when an attacker has plaintext access to the SCRAM authentication exchange. However, the usage of SCRAM over plaintext is strongly discouraged as it is considered an insecure practice [2]. Apache Kafka recommends deploying SCRAM exclusively with TLS encryption to protect SCRAM exchanges from interception [3]. Deployments using SCRAM with TLS are not affected by this issue. How to Detect If You Are Impacted: If your deployment uses SCRAM…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p7c9-8xx8-h74f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-56128

Advisory: Apache Kafka's SCRAM implementation Incorrectly Implements Authentication Algorithm
IDs: CVE-2024-56128, GHSA-p7c9-8xx8-h74f
Record: https://patchnext.com/advisories/cve-2024-56128 (revision 1, source checked 26 Oct 2026, 16:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.apache.kafka:kafka_2.13 3.8.1, 3.7.2; org.apache.kafka:kafka_2.12 3.8.1, 3.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.kafka:kafka_2.10: affected >= 0.10.2.0, <= 0.10.2.2
- Maven org.apache.kafka:kafka_2.13: affected >= 0.10.2.0, < 3.7.2; >= 3.8.0, <= 3.8.0; fixed in 3.8.1, 3.7.2
- Maven org.apache.kafka:kafka_2.12: affected >= 0.10.2.0, < 3.7.2; >= 3.8.0, <= 3.8.0; fixed in 3.8.1, 3.7.2
- Maven org.apache.kafka:kafka_2.11: affected >= 0.10.2.0, <= 2.4.1

## Suggested inspection (read-only)
- Maven org.apache.kafka:kafka_2.10: check the installed version with your package manager.
- Maven org.apache.kafka:kafka_2.13: check the installed version with your package manager.
- Maven org.apache.kafka:kafka_2.12: check the installed version with your package manager.
- Maven org.apache.kafka:kafka_2.11: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.kafka:kafka_2.10, org.apache.kafka:kafka_2.13, org.apache.kafka:kafka_2.12, org.apache.kafka:kafka_2.11.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p7c9-8xx8-h74f (GitHub-reviewed advisory GHSA-p7c9-8xx8-h74f lists affected ranges: Maven org.apache.kafka:kafka_2.13 >=0.10.2.0 =3.8.0 =0.10.2.0 =3.8.0 =0.10.2.0 =0.10.2.0 <=0.10.2.2)

Commands are suggestions: review each one before running it.

Loading voting…