thorsten/phpmyfaq Unintended File Download Triggered by Embedded Frames
CVE-2024-55889GHSA-m3r7-8gw7-qwvc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (thorsten/phpmyfaq 3.2.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist thorsten/phpmyfaq
- Affected
- < 3.2.10
- Fixed in
- 3.2.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m3r7-8gw7-qwvc lists affected ranges: Packagist thorsten/phpmyfaq >=0 <3.2.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2024-55889: 2.19% estimated exploitation activity in the next 30 days; percentile 82.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A vulnerability exists in the FAQ Record component where a privileged attacker can trigger a file download on a victim's machine upon page visit by embedding it in an <iframe element without user interaction or explicit consent. Details In http://localhost/admin/index.php?action=editentry&id=20&lang=en, where a FAQ record is either created or edited, an attacker can insert an iframe, as "source code", pointing to a prior "malicious" attachment that the attacker has uploaded via FAQ "new attachment" upload, such that any page visits to this FAQ will trigger an automated download (from the edit screen, download is automated; from the faq page view as a normal user, depending on the browser, a pop up confirmation may be presented before the actual download. Firebox browser, for instance, does not require any interactions). PoC 1. create a new FAQ record and upload a "malicious" file - in my case, I uploaded an eicar file. take note of the uri, ie <p<iframe…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m3r7-8gw7-qwvc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-55889 Advisory: thorsten/phpmyfaq Unintended File Download Triggered by Embedded Frames IDs: CVE-2024-55889, GHSA-m3r7-8gw7-qwvc Record: https://patchnext.com/advisories/cve-2024-55889 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: thorsten/phpmyfaq 3.2.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist thorsten/phpmyfaq: affected < 3.2.10; fixed in 3.2.10 ## Suggested inspection (read-only) - Packagist thorsten/phpmyfaq: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on thorsten/phpmyfaq. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m3r7-8gw7-qwvc (GitHub-reviewed advisory GHSA-m3r7-8gw7-qwvc lists affected ranges: Packagist thorsten/phpmyfaq >=0 <3.2.10) Commands are suggestions: review each one before running it.
Loading voting…