Skip to content

← Actionable
Critical, CVSS 9.1

XWiki allows RCE from script right in configurable sections

CVE-2024-55879GHSA-r279-47wg-chpr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-administration-ui 16.3.0, 15.10.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2024-55879: 1.07% estimated exploitation activity in the next 30 days; percentile 64.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Any user with script rights can perform arbitrary remote code execution by adding instances of XWiki.ConfigurableClass to any page. This compromises the confidentiality, integrity and availability of the whole XWiki installation. To reproduce on a instance, as a user with script rights, edit your user profile and add an object of type XWiki.ConfigurableClass ("Custom configurable sections"). Set "Display in section" and "Display in category" to other, "Scope" to Wiki and all spaces and "Heading" to: Save the page and view it, then add ?sheet=XWiki.AdminSheet&viewer=content&section=other to the URL. If the logs contain "attacker - Attack from Heading succeeded!", then the instance is vulnerable. Patches This has been patched in XWiki 15.10.9 and 16.3.0. Workarounds We're not aware of any workaround except upgrading. References https://jira.xwiki.org/browse/XWIKI-21207 https://github.com/xwiki/xwiki-platform/commit/8493435ff9606905a2d913607d6c79862d0c168d For more information If…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r279-47wg-chpr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-55879

Advisory: XWiki allows RCE from script right in configurable sections
IDs: CVE-2024-55879, GHSA-r279-47wg-chpr
Record: https://patchnext.com/advisories/cve-2024-55879 (revision 1, source checked 26 Oct 2026, 16:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-administration-ui 16.3.0, 15.10.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-administration-ui: affected >= 2.3, < 15.10.9; >= 16.0.0-rc-1, < 16.3.0; fixed in 15.10.9, 16.3.0

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-administration-ui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-administration-ui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r279-47wg-chpr (GitHub-reviewed advisory GHSA-r279-47wg-chpr lists affected ranges: Maven org.xwiki.platform:xwiki-platform-administration-ui >=2.3 =16.0.0-rc-1 <16.3.0)

Commands are suggestions: review each one before running it.

Loading voting…