XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
CVE-2024-55877GHSA-2r87-74cx-2p7c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-help-ui 16.5.0, 16.4.1, 15.10.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-help-ui
- Affected
- >= 9.7-rc-1, < 15.10.11>= 16.0.0-rc-1, < 16.4.1>= 16.5.0-rc-1, < 16.5.0
- Fixed in
- 15.10.11, 16.4.1, 16.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2r87-74cx-2p7c lists affected ranges: Maven org.xwiki.platform:xwiki-platform-help-ui >=9.7-rc-1 =16.0.0-rc-1 =16.5.0-rc-1 <16.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2024-55877: 1.60% estimated exploitation activity in the next 30 days; percentile 75.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Any user with an account can perform arbitrary remote code execution by adding instances of XWiki.WikiMacroClass to any page. This compromises the confidentiality, integrity and availability of the whole XWiki installation. To reproduce on a instance, as a connected user without script nor programming rights, go to your user profile and add an object of type XWiki.WikiMacroClass. Set "Macro Id", "Macro Name" and "Macro Code" to any value, "Macro Visibility" to Current User and "Macro Description" to {{async}}{{groovy}}println("Hello from User macro!"){{/groovy}}{{/async}}. Save the page, then go to <host/xwiki/bin/view/XWiki/XWikiSyntaxMacrosList. If the description of your new macro reads "Hello from User macro!", then your instance is vulnerable. Patches This vulnerability has been fixed in XWiki 15.10.11, 16.4.1 and 16.5.0. Workarounds It is possible to manually apply this patch to the page XWiki.XWikiSyntaxMacrosList. References https://jira.xwiki.org/browse/XWIKI-22030…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2r87-74cx-2p7c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-55877 Advisory: XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList IDs: CVE-2024-55877, GHSA-2r87-74cx-2p7c Record: https://patchnext.com/advisories/cve-2024-55877 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-help-ui 16.5.0, 16.4.1, 15.10.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-help-ui: affected >= 9.7-rc-1, < 15.10.11; >= 16.0.0-rc-1, < 16.4.1; >= 16.5.0-rc-1, < 16.5.0; fixed in 15.10.11, 16.4.1, 16.5.0 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-help-ui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-help-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2r87-74cx-2p7c (GitHub-reviewed advisory GHSA-2r87-74cx-2p7c lists affected ranges: Maven org.xwiki.platform:xwiki-platform-help-ui >=9.7-rc-1 =16.0.0-rc-1 =16.5.0-rc-1 <16.5.0) Commands are suggestions: review each one before running it.
Loading voting…