http4k has a potential XXE (XML External Entity Injection) vulnerability
CVE-2024-55875GHSA-7mj5-hjjj-8rgw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.http4k:http4k-format-xml 6.50.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.http4k:http4k-format-xml
- Affected
- < 6.50.0.0
- Fixed in
- 6.50.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7mj5-hjjj-8rgw lists affected ranges: Maven org.http4k:http4k-format-xml >=0 <6.50.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-55875: 1.91% estimated exploitation activity in the next 30 days; percentile 79.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Short summary of the problem. Make the impact and severity as clear as possible. For example: An unsafe deserialization vulnerability allows any unauthenticated user to execute arbitrary code on the server. There is a potential XXE(XML External Entity Injection) vulnerability when http4k handling malicious XML contents within requests, which might allow attackers to read local sensitive information on server, trigger Server-side Request Forgery and even execute code under some circumstances. Details Give all details on the vulnerability. Pointing to the incriminated source code is very helpful for the maintainer. https://github.com/http4k/http4k/blob/25696dff2d90206cc1da42f42a1a8dbcdbcdf18c/core/format/xml/src/main/kotlin/org/http4k/format/Xml.kt#L42-L46 XML contents is parsed with DocumentBuilder without security settings on or external entity enabled PoC Complete instructions, including specific configuration details, to reproduce the vulnerability. Example Vulnerable…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7mj5-hjjj-8rgw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-55875 Advisory: http4k has a potential XXE (XML External Entity Injection) vulnerability IDs: CVE-2024-55875, GHSA-7mj5-hjjj-8rgw Record: https://patchnext.com/advisories/cve-2024-55875 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.http4k:http4k-format-xml 6.50.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.http4k:http4k-format-xml: affected < 6.50.0.0; fixed in 6.50.0.0 ## Suggested inspection (read-only) - Maven org.http4k:http4k-format-xml: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.http4k:http4k-format-xml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7mj5-hjjj-8rgw (GitHub-reviewed advisory GHSA-7mj5-hjjj-8rgw lists affected ranges: Maven org.http4k:http4k-format-xml >=0 <6.50.0.0) Commands are suggestions: review each one before running it.
Loading voting…