XWiki allows remote code execution through the extension sheet
CVE-2024-55662GHSA-j2pq-22jj-4pm5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-repository-server-ui 16.3.0, 15.10.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-repository-server-ui
- Affected
- >= 3.3-milestone-1, < 15.10.9>= 16.0.0-rc-1, < 16.3.0
- Fixed in
- 15.10.9, 16.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j2pq-22jj-4pm5 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-repository-server-ui >=3.3-milestone-1 =16.0.0-rc-1 <16.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2024-55662: 0.79% estimated exploitation activity in the next 30 days; percentile 56.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact On instances where Extension Repository Application is installed, any user can execute any code requiring programming rights on the server. In order to reproduce on an instance, as a normal user without script nor programming rights, go to your profile and add an object of type ExtensionCode.ExtensionClass. Set the description to {{async}}{{groovy}}println("Hello from Description"){{/groovy}}{{/async}} and press Save and View. If the description displays as Hello from Description without any error, then the instance is vulnerable. Patches This vulnerability has been fixed in XWiki 15.10.9 and 16.3.0. Workarounds Since Extension Repository Application is not mandatory, it can be safely disabled on instances that do not use it. It is also possible to manually apply this patch to the page ExtensionCode.ExtensionSheet, as well as this patch to the page ExtensionCode.ExtensionAuthorsDisplayer. References https://jira.xwiki.org/browse/XWIKI-21890…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j2pq-22jj-4pm5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-55662 Advisory: XWiki allows remote code execution through the extension sheet IDs: CVE-2024-55662, GHSA-j2pq-22jj-4pm5 Record: https://patchnext.com/advisories/cve-2024-55662 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-repository-server-ui 16.3.0, 15.10.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-repository-server-ui: affected >= 3.3-milestone-1, < 15.10.9; >= 16.0.0-rc-1, < 16.3.0; fixed in 15.10.9, 16.3.0 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-repository-server-ui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-repository-server-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j2pq-22jj-4pm5 (GitHub-reviewed advisory GHSA-j2pq-22jj-4pm5 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-repository-server-ui >=3.3-milestone-1 =16.0.0-rc-1 <16.3.0) Commands are suggestions: review each one before running it.
Loading voting…