Skip to content

← Actionable
Medium, CVSS 4.3amended

Predictable results in nanoid generation when given non-integer values

CVE-2024-55565GHSA-mwcw-c2x4-8c55

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nanoid 5.0.9, 3.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm nanoid

    Affected
    >= 4.0.0, < 5.0.9< 3.3.8
    Fixed in
    5.0.9, 3.3.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2024-55565: 0.66% estimated exploitation activity in the next 30 days; percentile 51.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When nanoid is called with a fractional value, there were a number of undesirable effects: 1. in browser and non-secure, the code infinite loops on while (size--) 2. in node, the value of poolOffset becomes fractional, causing calls to nanoid to return zeroes until the pool is next filled 3. if the first call in node is a fractional argument, the initial buffer allocation fails with an error Version 3.3.8 and 5.0.9 are fixed.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mwcw-c2x4-8c55

  2. Revision 1 · created ·

    Published from osv record GHSA-mwcw-c2x4-8c55

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-55565

Advisory: Predictable results in nanoid generation when given non-integer values
IDs: CVE-2024-55565, GHSA-mwcw-c2x4-8c55
Record: https://patchnext.com/advisories/cve-2024-55565 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nanoid 5.0.9, 3.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nanoid: affected >= 4.0.0, < 5.0.9; < 3.3.8; fixed in 5.0.9, 3.3.8

## Suggested inspection (read-only)
- `npm ls nanoid --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nanoid.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mwcw-c2x4-8c55 (OSV record GHSA-mwcw-c2x4-8c55 lists affected ranges: npm nanoid >=4.0.0 =0 <3.3.8 (fixed))
- Verified: https://github.com/advisories/GHSA-mwcw-c2x4-8c55 (GitHub-reviewed advisory GHSA-mwcw-c2x4-8c55 lists affected ranges: npm nanoid >=4.0.0 =0 <3.3.8)

Commands are suggestions: review each one before running it.

Loading voting…