Skip to content

← Actionable
Critical, CVSS 9.8amended

Remote code execution in pytorch lightning

CVE-2024-5452GHSA-cgwc-qvrx-rf7f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lightning 2.3.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-5452: 26.83% estimated exploitation activity in the next 30 days; percentile 98.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A remote code execution (RCE) vulnerability exists in the lightning-ai/pytorch-lightning library version 2.2.1 due to improper handling of deserialized user input and mismanagement of dunder attributes by the deepdiff library. The library uses deepdiff.Delta objects to modify application state based on frontend actions. However, it is possible to bypass the intended restrictions on modifying dunder attributes, allowing an attacker to construct a serialized delta that passes the deserializer whitelist and contains dunder attributes. When processed, this can be exploited to access other modules, classes, and instances, leading to arbitrary attribute write and total RCE on any self-hosted pytorch-lightning application in its default configuration, as the delta endpoint is enabled by default.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cgwc-qvrx-rf7f

  2. Revision 1 · created ·

    Published from osv record GHSA-cgwc-qvrx-rf7f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-5452

Advisory: Remote code execution in pytorch lightning
IDs: CVE-2024-5452, GHSA-cgwc-qvrx-rf7f
Record: https://patchnext.com/advisories/cve-2024-5452 (revision 2, source checked 26 Oct 2026, 13:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lightning 2.3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI lightning: affected < 2.3.3; fixed in 2.3.3

## Suggested inspection (read-only)
- `python -m pip show lightning`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lightning.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cgwc-qvrx-rf7f (OSV record GHSA-cgwc-qvrx-rf7f lists affected ranges: PyPI lightning >=0 <2.3.3 (fixed))
- Verified: https://github.com/advisories/GHSA-cgwc-qvrx-rf7f (GitHub-reviewed advisory GHSA-cgwc-qvrx-rf7f lists affected ranges: PyPI lightning >=0 <2.3.3)

Commands are suggestions: review each one before running it.

Loading voting…