Remote Code Execution via path traversal bypass in lollms
CVE-2024-5443GHSA-mvrm-fh8q-6wr2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lollms 9.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI lollms
- Affected
- >= 5.9.0, < 9.5.1
- Fixed in
- 9.5.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mvrm-fh8q-6wr2 lists affected ranges: PyPI lollms >=5.9.0 <9.5.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mvrm-fh8q-6wr2 lists affected ranges: PyPI lollms >=5.9.0 <9.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-5443: 1.16% estimated exploitation activity in the next 30 days; percentile 67.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
CVE-2024-4320 describes a vulnerability in the parisneo/lollms software, specifically within the ExtensionBuilder().buildextension() function. The vulnerability arises from the /mountextension endpoint, where a path traversal issue allows attackers to navigate beyond the intended directory structure. This is facilitated by the data.category and data.folder parameters accepting empty strings (""), which, due to inadequate input sanitization, can lead to the construction of a packagepath that points to the root directory. Consequently, if an attacker can create a config.yaml file in a controllable path, this path can be appended to the extensions list and trigger the execution of init.py in the current directory, leading to remote code execution. The vulnerability affects versions from 5.9.0, and has been addressed in version 9.5.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mvrm-fh8q-6wr2
- Revision 1 · created ·
Published from osv record GHSA-mvrm-fh8q-6wr2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-5443 Advisory: Remote Code Execution via path traversal bypass in lollms IDs: CVE-2024-5443, GHSA-mvrm-fh8q-6wr2 Record: https://patchnext.com/advisories/cve-2024-5443 (revision 2, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lollms 9.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI lollms: affected >= 5.9.0, < 9.5.1; fixed in 9.5.1 ## Suggested inspection (read-only) - `python -m pip show lollms`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lollms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mvrm-fh8q-6wr2 (OSV record GHSA-mvrm-fh8q-6wr2 lists affected ranges: PyPI lollms >=5.9.0 <9.5.1 (fixed)) - Verified: https://github.com/advisories/GHSA-mvrm-fh8q-6wr2 (GitHub-reviewed advisory GHSA-mvrm-fh8q-6wr2 lists affected ranges: PyPI lollms >=5.9.0 <9.5.1) Commands are suggestions: review each one before running it.
Loading voting…