Skip to content

← Actionable
High, CVSS 7.5amended

Directus allows unauthenticated access to WebSocket events and operations

CVE-2024-54151GHSA-849r-qrwj-8rv4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.3.0; @directus/api 23.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    >= 11.0.0, < 11.3.0
    Fixed in
    11.3.0
  • npm @directus/api

    Affected
    >= 22.2.0, < 23.2.0
    Fixed in
    23.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-54151: 0.69% estimated exploitation activity in the next 30 days; percentile 53.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When setting WEBSOCKETSGRAPHQLAUTH or WEBSOCKETSRESTAUTH to "public", an unauthenticated user is able to do any of the supported operations (CRUD, subscriptions) with full admin privileges. Details Accountability for unauthenticated WebSocket requests is set to null, which used to be "public permissions" until the Permissions Policy update which now defaults that to system/admin level access. So instead of null we need to make use of createDefaultAccountability() to ensure public permissions are used for unauthenticated users. PoC 1. Start directus with 2. Subscribe using GQL or REST or do any CRUD operation on a user created collection (system tables are not reachable with crud) or 3a. Open up the data studio as any user. Observe how the subscriber gets notified on each page navigation (because the users lastpage gets updated, the password fields is properly redacted here) 3b. Observe receiving all available items from the yourcollectionname collection. Impact This impacts…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-849r-qrwj-8rv4

  2. Revision 1 · created ·

    Published from osv record GHSA-849r-qrwj-8rv4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-54151

Advisory: Directus allows unauthenticated access to WebSocket events and operations
IDs: CVE-2024-54151, GHSA-849r-qrwj-8rv4
Record: https://patchnext.com/advisories/cve-2024-54151 (revision 2, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 11.3.0; @directus/api 23.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected >= 11.0.0, < 11.3.0; fixed in 11.3.0
- npm @directus/api: affected >= 22.2.0, < 23.2.0; fixed in 23.2.0

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @directus/api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus, @directus/api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-849r-qrwj-8rv4 (OSV record GHSA-849r-qrwj-8rv4 lists affected ranges: npm directus >=11.0.0 =22.2.0 <23.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-849r-qrwj-8rv4 (GitHub-reviewed advisory GHSA-849r-qrwj-8rv4 lists affected ranges: npm directus >=11.0.0 =22.2.0 <23.2.0)

Commands are suggestions: review each one before running it.

Loading voting…