Skip to content

← Actionable
High, CVSS 8.7

Remote Command Execution in file editing in gogs

CVE-2024-54148GHSA-r7j8-5h9c-f6fx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gogs.io/gogs 0.13.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-54148: 0.85% estimated exploitation activity in the next 30 days; percentile 58.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The malicious user is able to commit and edit a crafted symlink file to a repository to gain SSH access to the server. Patches Editing symlink while changing the file name has been prohibited via the repository web editor (https://github.com/gogs/gogs/pull/7857). Users should upgrade to 0.13.1 or the latest 0.14.0+dev. Workarounds No viable workaround available, please only grant access to trusted users to your Gogs instance on affected versions. References n/a Proof of Concept 1. Create two repositories, upload something to the first repository, edit any file, and save it on the webpage. 2. In the second repository, create a symbolic link to the file you need to edit: 3. Go back to the webpage, edit the symbolic file in the second repository, with the following content, change the filename, and save (here you can notice, with filename changed the symbolic file edit limit is bypassed) 4. Go back to the first repo, edit something, and commit again, you can notice a file called…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r7j8-5h9c-f6fx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-54148

Advisory: Remote Command Execution in file editing in gogs
IDs: CVE-2024-54148, GHSA-r7j8-5h9c-f6fx
Record: https://patchnext.com/advisories/cve-2024-54148 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gogs.io/gogs 0.13.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go gogs.io/gogs: affected < 0.13.1; fixed in 0.13.1

## Suggested inspection (read-only)
- Go gogs.io/gogs: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gogs.io/gogs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r7j8-5h9c-f6fx (GitHub-reviewed advisory GHSA-r7j8-5h9c-f6fx lists affected ranges: Go gogs.io/gogs >=0 <0.13.1)

Commands are suggestions: review each one before running it.

Loading voting…