Skip to content

← Actionable
High, CVSS 7.8

phpMyFAQ Generates an Error Message Containing Sensitive Information if database server is not available

CVE-2024-54141GHSA-vrjr-p3xp-xx2x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (thorsten/phpmyfaq 4.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2024-54141: 0.49% estimated exploitation activity in the next 30 days; percentile 42.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Exposure of database (ie postgreSQL) server's credential when connection to DB fails. Details Exposed database credentials upon misconfig/DoS @ permalink: https://github.com/thorsten/phpMyFAQ/blob/main/phpmyfaq/src/phpMyFAQ/Setup/Installer.php#L694 PoC When postgreSQL server is unreachable, an error would be thrown exposing the credentials of the database. For instance, when "http://<phpmyfaq-instance:8080/setup/index.php" is hit when the database instance/server is down, then credentials are exposed, for instance: A way to force this would be to perform a denial of service on the database instance/server. When the db connection is refused, the credentials would show. The remote attacker can then use that to gain full control on the database. Impact This vulnerability exposes the credentials of the database and grants a remote attacker full control over the database. First notified Snyk on 16 Jan 2024.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vrjr-p3xp-xx2x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-54141

Advisory: phpMyFAQ Generates an Error Message Containing Sensitive Information if database server is not available
IDs: CVE-2024-54141, GHSA-vrjr-p3xp-xx2x
Record: https://patchnext.com/advisories/cve-2024-54141 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: thorsten/phpmyfaq 4.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist thorsten/phpmyfaq: affected < 4.0.0; fixed in 4.0.0

## Suggested inspection (read-only)
- Packagist thorsten/phpmyfaq: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on thorsten/phpmyfaq.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vrjr-p3xp-xx2x (GitHub-reviewed advisory GHSA-vrjr-p3xp-xx2x lists affected ranges: Packagist thorsten/phpmyfaq >=0 <4.0.0)

Commands are suggestions: review each one before running it.

Loading voting…