Possible Content Security Policy bypass in Action Dispatch
CVE-2024-54133GHSA-vfm5-rmrh-j26v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (actionpack 8.0.0.1, 7.2.2.1, 7.1.5.1, 7.0.8.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems actionpack
- Affected
- >= 5.2.0, < 7.0.8.7>= 7.1.0, < 7.1.5.1>= 7.2.0, < 7.2.2.1>= 8.0.0, < 8.0.0.1
- Fixed in
- 7.1.5.1, 8.0.0.1, 7.0.8.7, 7.2.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vfm5-rmrh-j26v lists affected ranges: RubyGems actionpack >=5.2.0 =7.1.0 =7.2.0 =8.0.0 <8.0.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2024-54133: 1.00% estimated exploitation activity in the next 30 days; percentile 62.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is a possible Cross Site Scripting (XSS) vulnerability in the contentsecuritypolicy helper in Action Pack. Impact ------ Applications which set Content-Security-Policy (CSP) headers dynamically from untrusted user input may be vulnerable to carefully crafted inputs being able to inject new directives into the CSP. This could lead to a bypass of the CSP and its protection against XSS and other attacks. Releases -------- The fixed releases are available at the normal locations. Workarounds ----------- Applications can avoid setting CSP headers dynamically from untrusted input, or can validate/sanitize that input. Credits ------- Thanks to ryotak for the report!
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vfm5-rmrh-j26v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-54133 Advisory: Possible Content Security Policy bypass in Action Dispatch IDs: CVE-2024-54133, GHSA-vfm5-rmrh-j26v Record: https://patchnext.com/advisories/cve-2024-54133 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: actionpack 8.0.0.1, 7.2.2.1, 7.1.5.1, 7.0.8.7. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems actionpack: affected >= 5.2.0, < 7.0.8.7; >= 7.1.0, < 7.1.5.1; >= 7.2.0, < 7.2.2.1; >= 8.0.0, < 8.0.0.1; fixed in 7.1.5.1, 8.0.0.1, 7.0.8.7, 7.2.2.1 ## Suggested inspection (read-only) - RubyGems actionpack: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on actionpack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vfm5-rmrh-j26v (GitHub-reviewed advisory GHSA-vfm5-rmrh-j26v lists affected ranges: RubyGems actionpack >=5.2.0 =7.1.0 =7.2.0 =8.0.0 <8.0.0.1) Commands are suggestions: review each one before running it.
Loading voting…