Skip to content

← Actionable
Medium, CVSS 5.7amended

Directus has an HTML Injection in Comment

CVE-2024-54128GHSA-r6wx-627v-gh2f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.2.2, 10.13.4; @directus/app 13.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    >= 10.10.0, < 10.13.4>= 11.0.0-rc.1, < 11.2.2
    Fixed in
    11.2.2, 10.13.4
  • npm @directus/app

    Affected
    >= 11.0.0, < 13.3.1
    Fixed in
    13.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-54128: 0.34% estimated exploitation activity in the next 30 days; percentile 27.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Comment feature has implemented a filter to prevent users from adding restricted characters, such as HTML tags. However, this filter operates on the client-side, which can be bypassed, making the application vulnerable to HTML Injection. Details The Comment feature implements a character filter on the client-side, this can be bypassed by directly sending a request to the endpoint. Example Request: Example Response: Example Result: Impact With the introduction of session cookies this issue has become exploitable as a malicious script is now able to do authenticated actions on the current users behalf.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r6wx-627v-gh2f

  2. Revision 1 · created ·

    Published from osv record GHSA-r6wx-627v-gh2f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-54128

Advisory: Directus has an HTML Injection in Comment
IDs: CVE-2024-54128, GHSA-r6wx-627v-gh2f
Record: https://patchnext.com/advisories/cve-2024-54128 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 11.2.2, 10.13.4; @directus/app 13.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected >= 10.10.0, < 10.13.4; >= 11.0.0-rc.1, < 11.2.2; fixed in 11.2.2, 10.13.4
- npm @directus/app: affected >= 11.0.0, < 13.3.1; fixed in 13.3.1

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @directus/app --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus, @directus/app.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r6wx-627v-gh2f (OSV record GHSA-r6wx-627v-gh2f lists affected ranges: npm @directus/app >=11.0.0 =10.10.0 =11.0.0-rc.1 <11.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-r6wx-627v-gh2f (GitHub-reviewed advisory GHSA-r6wx-627v-gh2f lists affected ranges: npm @directus/app >=11.0.0 =10.10.0 =11.0.0-rc.1 <11.2.2)

Commands are suggestions: review each one before running it.

Loading voting…