rails-html-sanitize has XSS vulnerability with certain configurations
CVE-2024-53985GHSA-w8gc-x259-rc7x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rails-html-sanitizer 1.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rails-html-sanitizer
- Affected
- >= 1.6.0, <= 1.6.0
- Fixed in
- 1.6.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w8gc-x259-rc7x lists affected ranges: RubyGems rails-html-sanitizer >=1.6.0 <=1.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2024-53985: 0.60% estimated exploitation activity in the next 30 days; percentile 48.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary There is a possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer 1.6.0 when used with Rails = 7.1.0 and Nokogiri < 1.15.7, or 1.16.x < 1.16.8. Versions affected: 1.6.0 Not affected: < 1.6.0 Fixed versions: 1.6.1 Please note that the fix in v1.6.1 is to update the dependency on Nokogiri to 1.15.7 or = 1.16.8. Impact A possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer may allow an attacker to inject content if HTML5 sanitization is enabled and the application developer has overridden the sanitizer's allowed tags in either of the following ways: allow both "math" and "style" elements or allow both "svg" and "style" elements Code is only impacted if Rails is configured to use HTML5 sanitization, please see documentation for config.actionview.sanitizervendor and config.actiontext.sanitizervendor for more information on these configuration options. Code is only impacted if allowed tags are being overridden. Applications may…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w8gc-x259-rc7x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-53985 Advisory: rails-html-sanitize has XSS vulnerability with certain configurations IDs: CVE-2024-53985, GHSA-w8gc-x259-rc7x Record: https://patchnext.com/advisories/cve-2024-53985 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rails-html-sanitizer 1.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rails-html-sanitizer: affected >= 1.6.0, <= 1.6.0; fixed in 1.6.1 ## Suggested inspection (read-only) - RubyGems rails-html-sanitizer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rails-html-sanitizer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w8gc-x259-rc7x (GitHub-reviewed advisory GHSA-w8gc-x259-rc7x lists affected ranges: RubyGems rails-html-sanitizer >=1.6.0 <=1.6.0) Commands are suggestions: review each one before running it.
Loading voting…