Skip to content

← Actionable
Medium, CVSS 4.3amended

Backstage Scaffolder plugin vulnerable to Server-Side Request Forgery

CVE-2024-53983GHSA-qmc2-jpr5-7rg9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-scaffolder-node 0.6.1, 0.5.1, 0.4.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2024-53983: 0.37% estimated exploitation activity in the next 30 days; percentile 31.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability is identified in Backstage Scaffolder template functionality where Server-Side Template Injection (SSTI) can be exploited to perform Git config injection. The vulnerability allows an attacker to capture privileged git tokens used by the Backstage Scaffolder plugin. With these tokens, unauthorized access to sensitive resources in git can be achieved. The impact is considered medium severity as the Backstage Threat Model recommends restricting access to adding and editing templates in the Backstage Catalog plugin. Patches The issue has been resolved in versions v0.4.12, v0.5.1 and v0.6.1 of the @backstage/plugin-scaffolder-node package. Users are encouraged to upgrade to this version to mitigate the vulnerability. Workarounds Users can ensure that templates do not change git config. References If you have any questions or comments about this advisory: Open an issue in the Backstage repository Visit our Discord, linked to in Backstage README

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qmc2-jpr5-7rg9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-qmc2-jpr5-7rg9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-53983

Advisory: Backstage Scaffolder plugin vulnerable to Server-Side Request Forgery
IDs: CVE-2024-53983, GHSA-qmc2-jpr5-7rg9
Record: https://patchnext.com/advisories/cve-2024-53983 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-scaffolder-node 0.6.1, 0.5.1, 0.4.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/plugin-scaffolder-node: affected < 0.4.12; >= 0.5.0, <= 0.5.0; >= 0.6.0, <= 0.6.0; fixed in 0.5.1, 0.6.1, 0.4.12

## Suggested inspection (read-only)
- `npm ls @backstage/plugin-scaffolder-node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/plugin-scaffolder-node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qmc2-jpr5-7rg9 (OSV record GHSA-qmc2-jpr5-7rg9 lists affected ranges: npm @backstage/plugin-scaffolder-node >=0 =0.5.0 =0.6.0 <0.6.1 (fixed))
- Verified: https://github.com/advisories/GHSA-qmc2-jpr5-7rg9 (GitHub-reviewed advisory GHSA-qmc2-jpr5-7rg9 lists affected ranges: npm @backstage/plugin-scaffolder-node >=0 =0.5.0 =0.6.0 <=0.6.0)

Commands are suggestions: review each one before running it.

Loading voting…