Skip to content

← Actionable
High, CVSS 8.7amended

Denial of service (DoS) via deformation multipart/form-data boundary

CVE-2024-53981GHSA-59g5-xgcq-4qw3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-multipart 0.0.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-53981: 0.64% estimated exploitation activity in the next 30 days; percentile 50.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When parsing form data, python-multipart skips line breaks (CR \r or LF \n) in front of the first boundary and any tailing bytes after the last boundary. This happens one byte at a time and emits a log event each time, which may cause excessive logging for certain inputs. An attacker could abuse this by sending a malicious request with lots of data before the first or after the last boundary, causing high CPU load and stalling the processing thread for a significant amount of time. In case of ASGI application, this could stall the event loop and prevent other requests from being processed, resulting in a denial of service (DoS). Impact Applications that use python-multipart to parse form data (or use frameworks that do so) are affected. Original Report This security issue was reported by: - GitHub security advisory in Starlette on October 30 by @Startr4ck - Email to python-multipart maintainer on October 3 by @mnqazi

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-59g5-xgcq-4qw3

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-59g5-xgcq-4qw3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-53981

Advisory: Denial of service (DoS) via deformation `multipart/form-data` boundary
IDs: CVE-2024-53981, GHSA-59g5-xgcq-4qw3
Record: https://patchnext.com/advisories/cve-2024-53981 (revision 3, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: python-multipart 0.0.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI python-multipart: affected < 0.0.18; fixed in 0.0.18

## Suggested inspection (read-only)
- `python -m pip show python-multipart`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on python-multipart.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-59g5-xgcq-4qw3 (OSV record GHSA-59g5-xgcq-4qw3 lists affected ranges: PyPI python-multipart >=0 <0.0.18 (fixed))
- Verified: https://github.com/advisories/GHSA-59g5-xgcq-4qw3 (GitHub-reviewed advisory GHSA-59g5-xgcq-4qw3 lists affected ranges: PyPI python-multipart >=0 <0.0.18)

Commands are suggestions: review each one before running it.

Loading voting…