Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled
CVE-2024-53949GHSA-35fc-9hrj-3585
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-superset 4.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-superset
- Affected
- >= 2.0.0, < 4.1.0
- Fixed in
- 4.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-35fc-9hrj-3585 lists affected ranges: PyPI apache-superset >=2.0.0 <4.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-35fc-9hrj-3585 lists affected ranges: PyPI apache-superset >=2.0.0 <4.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-53949: 0.72% estimated exploitation activity in the next 30 days; percentile 53.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Authorization vulnerability in Apache Superset when FABADDSECURITYAPI is enabled (disabled by default). Allows for lower privilege users to use this API. issue affects Apache Superset: from 2.0.0 before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-35fc-9hrj-3585
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-35fc-9hrj-3585
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-53949 Advisory: Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled IDs: CVE-2024-53949, GHSA-35fc-9hrj-3585 Record: https://patchnext.com/advisories/cve-2024-53949 (revision 3, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-superset 4.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-superset: affected >= 2.0.0, < 4.1.0; fixed in 4.1.0 ## Suggested inspection (read-only) - `python -m pip show apache-superset`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-superset. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-35fc-9hrj-3585 (OSV record GHSA-35fc-9hrj-3585 lists affected ranges: PyPI apache-superset >=2.0.0 <4.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-35fc-9hrj-3585 (GitHub-reviewed advisory GHSA-35fc-9hrj-3585 lists affected ranges: PyPI apache-superset >=2.0.0 <4.1.0) Commands are suggestions: review each one before running it.
Loading voting…