Apache Superset: Improper SQL authorisation, parse not checking for specific postgres functions
CVE-2024-53947GHSA-92qf-8gh3-gwcm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-superset 4.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-superset
- Affected
- < 4.1.0
- Fixed in
- 4.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-92qf-8gh3-gwcm lists affected ranges: PyPI apache-superset >=0 <4.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-92qf-8gh3-gwcm lists affected ranges: PyPI apache-superset >=0 <4.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N · score source
- EPSS
- CVE-2024-53947: 0.84% estimated exploitation activity in the next 30 days; percentile 57.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Superset. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. This issue is a follow-up to CVE-2024-39887 with additional disallowed PostgreSQL functions now included: querytoxmlandxmlschema, tabletoxml, tabletoxmlandxmlschema. This issue affects Apache Superset: <4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue or add these Postgres functions to the config set DISALLOWEDSQLFUNCTIONS.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-92qf-8gh3-gwcm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-92qf-8gh3-gwcm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-53947 Advisory: Apache Superset: Improper SQL authorisation, parse not checking for specific postgres functions IDs: CVE-2024-53947, GHSA-92qf-8gh3-gwcm Record: https://patchnext.com/advisories/cve-2024-53947 (revision 3, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-superset 4.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-superset: affected < 4.1.0; fixed in 4.1.0 ## Suggested inspection (read-only) - `python -m pip show apache-superset`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-superset. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-92qf-8gh3-gwcm (OSV record GHSA-92qf-8gh3-gwcm lists affected ranges: PyPI apache-superset >=0 <4.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-92qf-8gh3-gwcm (GitHub-reviewed advisory GHSA-92qf-8gh3-gwcm lists affected ranges: PyPI apache-superset >=0 <4.1.0) Commands are suggestions: review each one before running it.
Loading voting…