Skip to content

← Actionable
High, CVSS 8.4amended

virtualenv allows command injection through activation scripts for a virtual environment

CVE-2024-53899GHSA-rqc4-2hc7-8c8v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (virtualenv 20.26.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-53899: 1.57% estimated exploitation activity in the next 30 days; percentile 75.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

virtualenv before 20.26.6 allows command injection through the activation scripts for a virtual environment. Magic template strings are not quoted correctly when replacing. NOTE: this is not the same as CVE-2024-9287.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rqc4-2hc7-8c8v

  2. Revision 1 · created ·

    Published from osv record GHSA-rqc4-2hc7-8c8v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-53899

Advisory: virtualenv allows command injection through activation scripts for a virtual environment
IDs: CVE-2024-53899, GHSA-rqc4-2hc7-8c8v
Record: https://patchnext.com/advisories/cve-2024-53899 (revision 2, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: virtualenv 20.26.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI virtualenv: affected < 20.26.6; fixed in 20.26.6

## Suggested inspection (read-only)
- `python -m pip show virtualenv`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on virtualenv.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rqc4-2hc7-8c8v (OSV record GHSA-rqc4-2hc7-8c8v lists affected ranges: PyPI virtualenv >=0 <20.26.6 (fixed))
- Verified: https://github.com/advisories/GHSA-rqc4-2hc7-8c8v (GitHub-reviewed advisory GHSA-rqc4-2hc7-8c8v lists affected ranges: PyPI virtualenv >=0 <20.26.6)

Commands are suggestions: review each one before running it.

Loading voting…