Synapse Matrix has a partial room state leak via Sliding Sync
CVE-2024-53867GHSA-56w4-5538-8v8h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 1.120.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI matrix-synapse
- Affected
- >= 1.113.0rc1, < 1.120.1
- Fixed in
- 1.120.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-56w4-5538-8v8h lists affected ranges: PyPI matrix-synapse >=1.113.0rc1 <1.120.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-56w4-5538-8v8h lists affected ranges: PyPI matrix-synapse >=1.113.0rc1 <1.120.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2024-53867: 0.44% estimated exploitation activity in the next 30 days; percentile 38.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Sliding Sync feature on Synapse versions between 1.113.0rc1 and 1.120.0 can leak partial room state changes to users no longer in a room. Non-state events, like messages, are unaffected. Patches Synapse version 1.120.1 fixes the problem. Workarounds Disable Sliding Sync. References https://github.com/matrix-org/matrix-spec-proposals/pull/4186 https://github.com/element-hq/synapse/blob/d80cd57c54427687afcb48740d99219c88a0fff1/synapse/config/experimental.py#L341-L344 For more information If you have any questions or comments about this advisory, please email us at security at element.io.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-56w4-5538-8v8h
- Revision 1 · created ·
Published from osv record GHSA-56w4-5538-8v8h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-53867 Advisory: Synapse Matrix has a partial room state leak via Sliding Sync IDs: CVE-2024-53867, GHSA-56w4-5538-8v8h Record: https://patchnext.com/advisories/cve-2024-53867 (revision 2, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 1.120.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI matrix-synapse: affected >= 1.113.0rc1, < 1.120.1; fixed in 1.120.1 ## Suggested inspection (read-only) - `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on matrix-synapse. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-56w4-5538-8v8h (OSV record GHSA-56w4-5538-8v8h lists affected ranges: PyPI matrix-synapse >=1.113.0rc1 <1.120.1 (fixed)) - Verified: https://github.com/advisories/GHSA-56w4-5538-8v8h (GitHub-reviewed advisory GHSA-56w4-5538-8v8h lists affected ranges: PyPI matrix-synapse >=1.113.0rc1 <1.120.1) Commands are suggestions: review each one before running it.
Loading voting…