SPEmailHandler-PHP has Potential Abuse for Sending Arbitrary Emails
CVE-2024-53860GHSA-mj5r-x73q-fjw6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (spencer14420/sp-php-email-handler 1.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist spencer14420/sp-php-email-handler
- Affected
- < 1.0.0
- Fixed in
- 1.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mj5r-x73q-fjw6 lists affected ranges: Packagist spencer14420/sp-php-email-handler >=0 <1.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-53860: 0.46% estimated exploitation activity in the next 30 days; percentile 40.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Messages sent using this script are vulnerable to abuse, as the script allows anybody to specify arbitrary email recipients and include user-provided content in confirmation emails. This could enable malicious actors to use your server to send spam, phishing emails, or other malicious content, potentially damaging your domain's reputation and leading to blacklisting by email providers. Patches Patched in version 1.0.0 by removing user-provided content from confirmation emails. All pre-release versions (alpha and beta) are vulnerable to this issue and should not be used. Workarounds There are no workarounds for this issue. Users must upgrade to version 1.0.0 to mitigate the vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mj5r-x73q-fjw6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-53860 Advisory: SPEmailHandler-PHP has Potential Abuse for Sending Arbitrary Emails IDs: CVE-2024-53860, GHSA-mj5r-x73q-fjw6 Record: https://patchnext.com/advisories/cve-2024-53860 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: spencer14420/sp-php-email-handler 1.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist spencer14420/sp-php-email-handler: affected < 1.0.0; fixed in 1.0.0 ## Suggested inspection (read-only) - Packagist spencer14420/sp-php-email-handler: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on spencer14420/sp-php-email-handler. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mj5r-x73q-fjw6 (GitHub-reviewed advisory GHSA-mj5r-x73q-fjw6 lists affected ranges: Packagist spencer14420/sp-php-email-handler >=0 <1.0.0) Commands are suggestions: review each one before running it.
Loading voting…