Skip to content

← Actionable
Medium, CVSS 6.5

Recursive repository cloning can leak authentication tokens to non-GitHub submodule hosts

CVE-2024-53858GHSA-jwcm-9g39-pmcw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cli/cli/v2 2.63.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L
EPSS
  • CVE-2024-53858: 0.28% estimated exploitation activity in the next 30 days; percentile 20.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A security vulnerability has been identified in the GitHub CLI that could leak authentication tokens when cloning repositories containing git submodules hosted outside of GitHub.com and ghe.com. Details This vulnerability stems from several gh commands used to clone a repository with submodules from a non-GitHub host including gh repo clone, gh repo fork, gh pr checkout. These GitHub CLI commands invoke git with instructions to retrieve authentication tokens using the credential.helper configuration variable for any host encountered. Prior to 2.63.0, hosts other than GitHub.com and ghe.com are treated as GitHub Enterprise Server hosts and have tokens sourced from the following environment variables before falling back to host-specific tokens stored within system-specific secured storage: - GITHUBENTERPRISETOKEN - GHENTERPRISETOKEN - GITHUBTOKEN when CODESPACES environment variable is set The result being git sending authentication tokens when cloning submodules. In 2.63.0,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jwcm-9g39-pmcw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-53858

Advisory: Recursive repository cloning can leak authentication tokens to non-GitHub submodule hosts
IDs: CVE-2024-53858, GHSA-jwcm-9g39-pmcw
Record: https://patchnext.com/advisories/cve-2024-53858 (revision 1, source checked 26 Oct 2026, 15:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/cli/cli/v2 2.63.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/cli/cli/v2: affected <= 2.62.0; fixed in 2.63.0

## Suggested inspection (read-only)
- Go github.com/cli/cli/v2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/cli/cli/v2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jwcm-9g39-pmcw (GitHub-reviewed advisory GHSA-jwcm-9g39-pmcw lists affected ranges: Go github.com/cli/cli/v2 >=0 <=2.62.0)

Commands are suggestions: review each one before running it.

Loading voting…